LastPass .msi fails as it looks for powershell 1.0

Help with the Windows installer (lastpass.exe)

Moderators: admin, anatoly_LP, chantieLP, robyn, JoeSiegrist

LastPass .msi fails as it looks for powershell 1.0

Postby WillieGNYC » Mon Mar 09, 2020 11:37 am

All, Attempting to use the latest enterprise .msi for deploying to my company via SCCM. We are using this command line parameter.

msiexec /i "LastPassInstaller.msi" /qn /norestart ADDLOCAL=ExplorerExtension,ChromeExtension,FirefoxExtension,EdgeExtension,PasswordImporter,GenericShortcuts,BinaryComponent DISABLEPRINT=1 NODISABLECHROMEPWMGR=1 TRYENABLESIDELOADING=1 POWERSHELLVERSION=5.0 /L*V C:\Windows\CCM\Logs\InstallLastPass.log

The error we get is:
"This application requires PowerShell 1.0 or higher. Please install PowerShell and run this installer again"

We have powershell 2.0 and below disabled and uninstalled from our builds. the only approved version we have installed on every desktop is the more secure version powershell 5.0

is their an updated parameter? the command line i specified used to work and was provided by lastpass support
WillieGNYC
 
Posts: 1
Joined: Mon Mar 09, 2020 11:29 am

Re: LastPass .msi fails as it looks for powershell 1.0

Postby jpenny84 » Mon Mar 09, 2020 11:38 am

Contact enterprise phone support for direct assistance. The number can be found in the admin console.
jpenny84
 
Posts: 9164
Joined: Tue Mar 06, 2012 9:10 pm

Re: LastPass .msi fails as it looks for powershell 1.0

Postby bosspublic351 » Mon Jun 29, 2020 4:45 am

WillieGNYC Wrote:All, Attempting to use the latest enterprise .msi for deploying to my company via SCCM. We are using this command line parameter.

msiexec /i "LastPassInstaller.msi" /qn /norestart ADDLOCAL=ExplorerExtension,ChromeExtension,FirefoxExtension,EdgeExtension,PasswordImporter,GenericShortcuts,BinaryComponent DISABLEPRINT=1 NODISABLECHROMEPWMGR=1 TRYENABLESIDELOADING=1 POWERSHELLVERSION=5.0 /L*V C:\Windows\CCM\Logs\InstallLastPass.log

The error we get is:
"This application requires PowerShell 1.0 or higher. Please install PowerShell and run this installer again"

We have powershell 2.0 and below disabled and uninstalled from our builds. the only approved version we have installed on every desktop is the more secure version powershell 5.0

is their an updated parameter? the command line i specified used to work and was provided by lastpass support


Try adding this parameter to the end of the command POWERSHELLVERSION=<the version of powershell you have installed>
bosspublic351
 
Posts: 161
Joined: Fri Apr 18, 2014 10:18 am


Return to Windows Installer Questions

Who is online

Users browsing this forum: No registered users and 7 guests