Enterprise MSI Installer Behavior

Help with the Windows installer (lastpass.exe)

Moderators: admin, anatoly_LP, chantieLP, JoeSiegrist, robyn

Enterprise MSI Installer Behavior

Postby mmazurkiewicz572 » Thu Sep 05, 2019 10:58 am

I'm working on trying to deploy LastPass Enterprise to my organization and the MSI installer isn't behaving how I expect it to.

Based on the instructions I am trying to install as msiexec /quiet /i LastPassInstaller.msi so it installs all detected and supported browsers as well as the Windows application between both Windows 7 and 10 systems. What I'm experiencing is that the browser plugins get installed in Chrome, Firefox and IE but they are disabled by default. I don't want to have to send follow-up instructions to hundreds of users for how to enable the plugins.

Next, I've found that the plugin for Edge just doesn't get installed either, and I have some users that prefer to use it.

Meanwhile, if I use the LastPassInstaller.exe, everything gets installed without any issue, but I'd prefer to use the MSI so it can be deployed silently since the exe requires interaction and will raise questions.

Any advice for how to silently deploy this?
mmazurkiewicz572
 
Posts: 2
Joined: Thu Sep 05, 2019 10:52 am

Re: Enterprise MSI Installer Behavior

Postby kevinelwell262 » Tue Oct 01, 2019 1:15 pm

I ran the following command from an elevated command prompt:
msiexec /i LastPassInstaller.msi ALLUSERS=1 ADDLOCAL=ExplorerExtension,ChromeExtension,FirefoxExtension,EdgeExtension DISABLEPRINT=1 DISABLEEXPORT=1 NODISABLEIEPWMGR=1 NODISABLECHROMEPWMGR=1 /L*v LastPassMSI.log /qn
I referenced the instructions here: https://lastpass.com/company/#!/setting ... l-software
kevinelwell262
 
Posts: 2
Joined: Tue Oct 01, 2019 1:14 pm

Re: Enterprise MSI Installer Behavior

Postby kevinelwell262 » Tue Oct 01, 2019 1:29 pm

Instructions for which features and property's to set and software downloads can be found here: https://lastpass.com/company/#!/setting ... l-software

From an elevated command prompt i ran the following to test:

msiexec /i LastPassInstaller.msi ALLUSERS=1 ADDLOCAL=ExplorerExtension,ChromeExtension,FirefoxExtension,EdgeExtension DISABLEPRINT=1 DISABLEEXPORT=1 NODISABLEIEPWMGR=1 NODISABLECHROMEPWMGR=1 /L*v LastPassMSI.log /qn

After validating all of the features i wanted were installed successfully, i created a transform with all of the updated public properties and features. Then put that into our enterprise software deployment tool.
kevinelwell262
 
Posts: 2
Joined: Tue Oct 01, 2019 1:14 pm


Return to Windows Installer Questions

Who is online

Users browsing this forum: No registered users and 1 guest