LastPass does NOT work!

What do you love about LastPass? What do you hate about it? Tell us why you like it, why you don't, and why.

Moderators: admin, anatoly_LP, chantie, robyn, JoeSiegrist

LastPass does NOT work!

Postby kojaks43 » Thu Aug 05, 2010 11:21 am

Well, at least it does not work for me. The problem could be LastPass, Google Chrome, Win7 64bit (I am using LastPass for 64bit), or more likely, me! I am a newbie. Would not surprise me if I am doing everything wrong.

That said, I am not that much of a newbie, that I can't follow instructions. I do find LastPass instructions and screen steps confusing. And yes, I have read the manual (have found the manual is a bit behind the actual LastPass interface.)

I have written 4 topics in the "help me" area, and got 2 replies - not sure if 50% is good customer service or not. To be fair, one of those was written today, so the 50% crack was just my frustration leaking out.

Here is what I want. When I go to an old site, and enter my username and password and LastPass saves it, I want to then go to the site, and change my password to a stronger LastPass generated one. It is a crap shoot if I can do it. I tried with my American Express site, and it worked. I then tried it with my CapitalOne and CitiBank site and it was a complete failure. So much so, both sites are refusing to provide my Bank of America account with current amounts due! I am going to have to probably have each site cancel all my data so I can start from scratch. Actually, I don't know if the problem was my fault, a difference between LastPass and the banking sites or what, all I know is I cannot access those sites.

When LastPass successfully logs me into a chosen site, why offer to save the site? I find this very confusing.

When LastPass shows me the correct username and password and I've checked the auto-fill box, I expect LastPass to auto-fill the correct data. However it does not do that for my Google account. (subject of my last "help me" topic)

Alright, enough venting, I've got to get back to work.

But somebody, please help, either by fixing LastPass or teaching me what I am doing wrong.
kojaks43
 
Posts: 11
Joined: Sun Jul 11, 2010 5:52 am

Re: LastPass does NOT work!

Postby Israel » Thu Aug 05, 2010 1:20 pm

First off - the forum is mainly our way to connect users with other users who may be able to help. We do our best to stay on top of replies, but you'll always get the fastest support by using the support form on our website to email us.

http://lastpass.com/support_helpcenter.php


To generate a secure password, you can go to tools > generate secure password and copy/paste into the change password form on the website, then save the new site.

If it's not autofilling the correct data, delete the entry in your vault and recreate it with the correct login data.

http://helpdesk.lastpass.com may be a valuable resource for you as well.
Israel
Site Admin
 
Posts: 1475
Joined: Tue May 04, 2010 9:40 am

Re: LastPass does NOT work!

Postby bbarrick » Tue Sep 14, 2010 8:24 pm

I have had similar experiences. The problem is not LastPass, it's that the sites I deal with have not implemented credentials the same way in all cases. Usually the automated LP routine works but sometimes it doesn't. The most frequent problems seem to be with higher security sites like financial institutions. I think some of the non-standard fieldnames, multipage entry systems and other "enhancements" are probably deliberate to make brute force attacks harder. In one case I got locked out and had to get a manual reset.

Anyway, all of that said, one lives and learns. If the first automated attempt fails to populate the fields like it should, or the field arrangement looks non-standard, I do the manual thing (generate password) and I usually copy the generated password to my clipboard (on one occasion the Vault didn't save the generated password when I thought it should have--that's when I ended up needing a manual reset). This is probably as good as it gets but this is awfully good just the way it is.
bbarrick
 
Posts: 3
Joined: Sun Sep 12, 2010 2:27 pm


Return to Feedback

Who is online

Users browsing this forum: markkallin741, stacksmash5843 and 7 guests