LastPass and Xmarks broken on Firefox 56 64-bit

Xmarks support forums

Moderators: azitnay, admin, anatoly_LP, chantieLP, robyn, JoeSiegrist

LastPass and Xmarks broken on Firefox 56 64-bit

Postby DinoZuma » Sun Oct 01, 2017 5:21 pm

I am a longtime LastPass and Xmarks user, since both were emerging, independent and fledgling add-ons. While I like both very much, it looks like LastPass/Xmarks is lagging behind -- far behind -- other add-on developers. Here is the latest frustration on both my Windows 10 64-bit PCs running Firefox as the default browser:

Firefox just updated to version 56, and now both LastPass and Xmarks are broken because they are "Legacy" add-ons that are incompatible with the latest Web browser technology. Since the Firefox 56 update, LastPass won't populate login windows/popups and Xmarks won't sync bookmarks/favorites.

No solution that I can find easily is offered on the LastPass/Xmarks websites, nor on the forums. There are numerous complaints on the Firefox Add-In pages about this, however no response from the developer is provided.

The only solution is to try installing the beta add-ons found in the Development Channel drop-down menu. However, while the Xmarks beta works OK, the LastPass beta won't install at all, so I am stuck with using the semi-functional, now-it-works-now-it-doesn't "current version" LastPass Legacy add-on.

So, when are you going to provide apps that work on the latest version of Firefox, or on Edge for that matter? And please don't suggest that I jump to using Chrome: I value my privacy and Chrome does not.
DinoZuma
 
Posts: 2
Joined: Sun Oct 01, 2017 4:51 pm

Re: LastPass and Xmarks broken on Firefox 56 64-bit

Postby jpenny84 » Sun Oct 01, 2017 6:49 pm

jpenny84
 
Posts: 8381
Joined: Tue Mar 06, 2012 9:10 pm

Re: LastPass and Xmarks broken on Firefox 56 64-bit

Postby DinoZuma » Sun Oct 01, 2017 7:19 pm

jpenny84 Wrote:Try the development version.

https://addons.mozilla.org/en-US/firefo ... sions/beta


Did you misread my post, perhaps? OK, maybe TLDR, but as I stated, the Development Version of LastPass does not work in Firefox 56.
DinoZuma
 
Posts: 2
Joined: Sun Oct 01, 2017 4:51 pm

Re: LastPass and Xmarks broken on Firefox 56 64-bit

Postby chzuck » Thu Oct 26, 2017 9:02 pm

First problem I had was after a FF update Xmarks FF add-on became unresponsive. I saw where to download a new version of Xmarks and did so. Now the icon appears in the bar near my homepage icon, but all works until I run CCleaner then I lose my settings and need to go through setup then I am OK until I run CCleaner again. So who do we blame and who is really at fault for this mess?
chzuck
 
Posts: 6
Joined: Thu Oct 26, 2017 8:49 pm


Return to Xmarks

Who is online

Users browsing this forum: Google Feedfetcher and 2 guests