XMarks keeps reverting my bookmarks to an old version

Xmarks support forums

Moderators: azitnay, admin, anatoly_LP, chantieLP, robyn, JoeSiegrist

XMarks keeps reverting my bookmarks to an old version

Postby ncdave4life » Sun Jan 15, 2017 8:24 pm

I have a lot of bookmarks, and I use XMarks for Chrome (main browser), Firefox & IE 10, on two Win10 computers (my desktop and my laptop). I love the functionality, but the bugs are driving me crazy.

The Chrome extension reports its version as 1.0.32. The IE version is 1.3.17. The Firefox Add-on version is 4.3.19.

The worst bug I've encountered is that XMarks keeps undoing changes to my bookmarks!

I just noticed it happening again: My bookmarks have suddenly and silently reverted to an earlier version, in all my browsers.

Today is 1/15/2017. The "current" bookmarks are dated 1/14/2017, but they've reverted to an OLD version, or at least they've undone changes which were still included in the 1/13/2017 version.

In the bookmarks toolbar, I have a folder called "HTML etc". In that folder I have eleven sub-folders, called "Javascript," "PHP," "checkers, cleaners, validators, linters", "eCommerce and shopping carts," etc. Some months ago I used Chrome bookmarks manager to move many of the bookmarks from the "HTML etc" folder into various subfolders, to tidy things up.

Then, after some days or weeks had passed, I noticed that some of the bookmarks had been silently moved from the subfolders back into the "HTML etc" folder. So I repeated the reorganization.

It happened again, and I repeated the work again.

I've lost track of how many times it has happened, now -- I think it has been about five times. Sometimes I redo the reorganization work, organizing the bookmarks manually. At least one time I've just found an earlier bookmark set, which predated the damage, and reverted to it.

Either way, it keeps happening.

I think I'm losing at least some of my recently added bookmarks each time, too.

Today I noticed it sooner than usual. The "current" (damaged) bookmarks show yesterday's date (1/14/2017), and the previous bookmarks (1/13/2017) are undamaged (except that I think I'm missing a couple of new bookmarks that I think created yesterday -- I wish I could remember what they were).

I viewed the two bookmarks set versions in Chrome from my.xmarks.com -> Tools -> "Explore & Restore Old Bookmarks..." The URL links to them (when I'm logged in to my.xmarks.com) are:
https://my.xmarks.com/bookmarks/view/19 ... 01-13.html (the good one)
https://my.xmarks.com/bookmarks/view/19 ... 01-14.html (the mangled one)

I saved them both as HTML pages from Chrome, into two files: the mangled current (1/14/2017) version, and the undamaged previous (1/13/2017) version, so that I could compare them. Here's a screenshot of a visual compare of the two files. As you can see, 22 bookmarks have been moved from seven subfolders into the parent "HTML etc" folder:

http://www.burtonsys.com/xmarks_reverte ... gain01.png

The lines in the HTML file are very long, so they are truncated in that screenshot, but I can send the two saved bookmarks files to you if you wish.

I'd really like to understand what is going on, and prevent it from happening! The only clue I've noticed is that it only seems to happen when I use my laptop. Sometimes I go for weeks without using my laptop, and I don't think the problem has occurred during those periods.

I'm running the "Wappalyzer" and "uBlock Origin" extensions in Chrome on one computer, and "Adobe Acrobat" extension on the other - I doubt those could be causing the problem. In Chrome Settings (on both computers) I see a "Sign in to Chrome" button, so I'm sure Chrome is not trying to synchronize bookmarks.

I sure would like to get this solved!
ncdave4life
 
Posts: 14
Joined: Sun Jan 15, 2017 7:07 pm

Re: XMarks keeps reverting my bookmarks to an old version

Postby ncdave4life » Thu Jan 26, 2017 11:24 am

It just did it again.

This bug is driving me nuts.
ncdave4life
 
Posts: 14
Joined: Sun Jan 15, 2017 7:07 pm

Re: XMarks keeps reverting my bookmarks to an old version

Postby ncdave4life » Mon Jan 30, 2017 9:58 am

It just did it again.
ncdave4life
 
Posts: 14
Joined: Sun Jan 15, 2017 7:07 pm

Re: XMarks keeps reverting my bookmarks to an old version

Postby ncdave4life » Thu Feb 02, 2017 4:15 am

It just did it again! This bug is driving me crazy. Please, please, please try to fix it!

I have not had the laptop turned on since the last time I restored the bookmarks, so the Xmarks bug apparently is not triggered by using my laptop.

However, I think I might have narrowed it down to a bug in Xmarks for IE.

Just now I restored the old bookmarks again, using the Xmarks web interface (from Chrome). Then I synchronized both Chrome bookmarks (using the Xmarks extention in Chrome) and IE (using the Xmarks program for IE). (I haven't run Firefox yet.)

After the synchronization, I checked the bookmarks in Chrome, and they were correct.

But then I checked the IE Favorites (the old-fashioned way, from a command prompt, with a "dir" command), and they were still wrong.

Even though the Xmarks program for IE (v 1.3.21) reported that it had completed, with no errors, it actually had not correctly synchronized my Favorites.

So I went back into Xmarks for IE, went to the "Advanced" button, and had it "Download" (force overwrite of local Favorites). That worked. For the moment, at least, the Favorites folder is now correct.

The only other anomaly that I've noticed is that when I click on the the Xmarks for IE status when I open it seems to be stuck "Syncing successfully," even though the notification area icon still shows the plain Xmarks icon (no activity).

One other very tiny error: on the Advanced settings page, the Xmarks program for IE has an option (checked by default) to "Show Xmarks icon in systray." But there is no "systray" in Windows Vista, 7, 8 or 10. (I don't recall about XP.) Microsoft changed the name of the old "System Tray" to "Notification Area" at least a decade ago.

If the bug is in Xmarks for IE, I could live with it if there were an option to always download/overwrite the IE Favorites, and never upload them, because I hardly ever create new favorites within IE, anyhow. But there doesn't seem to be such an option.
ncdave4life
 
Posts: 14
Joined: Sun Jan 15, 2017 7:07 pm

Re: XMarks keeps reverting my bookmarks to an old version

Postby ncdave4life » Tue Mar 07, 2017 8:49 pm

It did it again.
ncdave4life
 
Posts: 14
Joined: Sun Jan 15, 2017 7:07 pm

Re: XMarks keeps reverting my bookmarks to an old version

Postby ncdave4life » Mon May 01, 2017 9:11 am

It did it again.

Is there any hope of this bug ever getting fixed, or at least looked at?
ncdave4life
 
Posts: 14
Joined: Sun Jan 15, 2017 7:07 pm

Re: XMarks keeps reverting my bookmarks to an old version

Postby ncdave4life » Fri Jun 16, 2017 12:35 pm

It happened again. The May 23 version of my bookmarks was okay, the May 25 version had been reverted.

(BTW, have I mentioned how grateful I am that you keep a "version control" history of the bookmarks, so that we can view and revert to old versions? That is a wonderful feature!!!)

Since I didn't notice the reversion right away, I had added quite a few added bookmarks since then, so I took a different approach to fixing it:

Step A. I exported/downloaded the three pertinent versions as HTML: the May 23 (last good), then May 25 (first bad), and the June 15 (latest).

Step B. Then I used a 3-way compare-and-merge tool (my own TLMerge, from TLIB Version Control, as it happens), to apply the May 25 -> May 23 change to the June 15 version.

Step C. Then I had a nice, fixed HTML bookmarks file... and I was stuck.

That's when I figured out that although XMarks has a bookmarks export-to-HTML feature, it has no way to import-from-HTML.

I tried importing the bookmarks file to Chrome, with the intent of then uploading from Chrome to XMarks, but that didn't work.

I finally gave up, and manually fixed the reverted bookmarks, one-by-one, again.

So, now I have two requests:

1. Please try to fix this bug!

2. Please add an import-from-uploaded-HTML-file feature (to go with the export-to-downloaded-HTML-file feature).

Well, three, actually. The other (simplest!) request is on another thread:

3. https://forums.lastpass.com/viewtopic.php?f=45&t=249115 ("Subject: Internal error while writing... couldn't move file")
ncdave4life
 
Posts: 14
Joined: Sun Jan 15, 2017 7:07 pm

Re: XMarks keeps reverting my bookmarks to an old version

Postby ncdave4life » Wed Sep 06, 2017 9:09 pm

XMarks just reverted my bookmarks again, the second time in the last week. Both times I noticed it before I had made a lot of new bookmarks, so I just used the Tools -> Explore and restore old bookmarks to first identify the last good version, and then restore it.

Please, is there any hope of ever getting this bug fixed?

I wonder if the bug has something to do with Firefox. I don't usually use Firefox, but I've been using it a bit, lately, for compatibility testing. I have the XMarks extension installed in Firefox, but it is pretty horribly broken. When I tell it to download the bookmarks, it just gets stuck forever.
ncdave4life
 
Posts: 14
Joined: Sun Jan 15, 2017 7:07 pm

Re: XMarks keeps reverting my bookmarks to an old version

Postby ncdave4life » Thu Sep 21, 2017 6:53 am

This bug just bit me again. Sometime between 10:42 a.m. and 11:11 a.m. yesterday my bookmarks reverted to an old version. As usual, many (but not all) of the bookmarks within 2nd-level folders in a folder on my bookmarks toolbar moved up one folder level.

Again, it happened when I had Firefox open, so my suspicion grows that the Firefox XMarks extension is the culprit.

In Firefox I see a sort of mishmash of the new & old versions of the bookmarks: the moved bookmarks are actually in BOTH the 2nd level folder and the 1st-level folder.

The XMarks Firefox extension doesn't work right, anyhow. It generally gets stuck and runs forever, when trying to synchronize -- a problem which has come and gone, on and off, for years. So I think I'll just remove the broken XMarks extension from Firefox.

That's a shame. It's bad enough that XMarks doesn't handle Edge and Opera. I guess we have to give up on it handling Firefox, too. That leaves just Chrome and IE -- better than nothing, but it's sure not what I wish it were. Still, if it avoids the effects of this awful bug, which has been plaguing me for more than a year, and has wasted many, many hours of my time, it will be worth giving up Firefox functionality.

SUGGESTION: Having download-only extensions for browsers like Firefox, Opera & Edge, which aren't fully supported by XMarks, would be a reasonable compromise, presumably easier than implementing full synchronization support. The extension wouldn't try to synchronize. Instead, whenever something changed in the master my.xmarks database, the Firefox/Opera/Edge extension would display an alert message, telling the user that the XMarks database has been updated via another browser, from containing xxx bookmarks to yyy bookmarks, and offering to let the user download those bookmarks/favorites, to replace the current bookmarks/favorites. Additionally, if the user added a bookmark/favorite within Firefox/Opera/Edge, the extension would display a warning, noting that the new bookmark will be lost if bookmarks are downloaded from my.xmarks, and suggesting that the user make it his habit to only add new bookmarks/favorites from within Chrome or IE.
ncdave4life
 
Posts: 14
Joined: Sun Jan 15, 2017 7:07 pm

Re: XMarks keeps reverting my bookmarks to an old version

Postby ncdave4life » Thu Sep 21, 2017 6:58 am

Note that "Legacy" Firefox extensions, like the XMarks extension, won't work when Firefox 57 is released, in November 2017, anyhow.
ncdave4life
 
Posts: 14
Joined: Sun Jan 15, 2017 7:07 pm

Next

Return to Xmarks

Who is online

Users browsing this forum: No registered users and 1 guest