Chromium Linux Xmarks

Xmarks support forums

Moderators: admin, azitnay, anatoly_LP, chantieLP, JoeSiegrist, robyn

Chromium Linux Xmarks

Postby lwb » Fri Jan 30, 2015 3:33 pm

I'm having an issue at the moment with Linux + Chromium (Version 37.0.2062.120 Built on Debian 7.6, running on Debian Kali Linux 1.0.9 (281580) (64-bit) + Xmarks.
It has been working fine in Windows, but in my Linux box it doesn't seem to work. I've not used it on Linux before, so I don't know if it ever worked or what has changed (only just installed it). The interesting thing is that it read from the server (did the initial sync) just fine. But so I've added a few bookmarks and then saw the status icon indicating there was an error.

The error is: bookmarks error: Error during sync changes: Invalid response object: {"status":-5,"errormsg":"Server 503 delay"},
When I went through to check the logs, I noticed 2 errors (and I am unsure if they are related)

This one:

[1/31/2015 5:34:41] >>> POST https://sync.xmarks.com/sync/bookmarks/getchanges xmarks-global.js:12
[1/31/2015 5:34:41] >>> Body is: {"baserev":"1098","manual":true,"log":{"mid":"i5j4pjm8"}} xmarks-global.js:12
[1/31/2015 5:34:41] Failed to create new password db, it probably exists. Attempting to load password data. Error: could not prepare statement (1 table 'lwb@xmarks.com-' already exists) xmarks-global.js:12
[1/31/2015 5:34:41] Finished loading from password store [lwb@xmarks.com-] xmarks-global.js:12

and this one:

[1/31/2015 5:35:00] Server 503: wants us to back off for 60 seconds xmarks-global.js:12
[1/31/2015 5:35:00] Response: {"status":503,"message":"User is read-only","auth":"DEADBEEFD34DB33FDEADBeEFDeADBEeFYiLCJfY3JlYXRlZCI6IjIwMTUwMTMwMTgzNjM0In0="} xmarks-global.js:12
[1/31/2015 5:35:00] >>> Callback {"status":-5,"errormsg":"Server 503 delay"} xmarks-global.js:12
[1/31/2015 5:35:00] Invalid response object: {"status":-5,"errormsg":"Server 503 delay"} xmarks-global.js:12
[1/31/2015 5:35:00] passwords sync is currently disabled, skipping synchronization xmarks-global.js:12
[1/31/2015 5:35:00] Sending new tab state xmarks-global.js:12

(obviously that's not my real auth hash nor usernames.

Now the strange thing is that it seems to download fine but it is uploading that has the prolblem. I did another full download from server, it comes good.
Then I add a new bookmark and it refuses to sync upstream.

I find it very interesting that it says ""status":503,"message":"User is read-only","auth":"DEADBEEFxxxx" and Server 503 delay.
Meanwhile, the user is definitely not read-only because amid all this I test on Windows + Chrome and it works fine.
Anyone else seen/experienced this or know what could be causing it?

Thanks
lwb
 
Posts: 4
Joined: Fri Jan 30, 2015 2:58 pm

Re: Chromium Linux Xmarks

Postby dmitrijLP » Sun Feb 01, 2015 11:52 am

Looks like the original issue was caused by duplicate bookmark synchronization, I have resolved that for your Xmarks account.

Double check that you disable all of the 3rd party bookmark synchronization as per:

http://helpdesk.xmarks.com/troubleshoot ... okmarks-2/

Try re-installing the Xmarks extension once again.

Kind regards,
Dmitrij
dmitrijLP
 
Posts: 1332
Joined: Mon Jun 23, 2014 8:46 am

Re: Chromium Linux Xmarks

Postby lwb » Sat Feb 21, 2015 7:10 am

Thanks Dimitri,

So I have been using xmarks for a while - I don't use any third party bookmark managers (used to use delicious until I found out about xmarks) and I use Supersorter manually to organiser them on-demand (not automatic). What I mean, is I disable chrome bookmarks sync and don't use anything else for syncing passwords other than xmarks - it does almost 100% what I need (short of spacers/sorting functions).

The problem is I rely heavily on xmarks but since this date I originally posted this, I have now found I have the same problem on windows as well (this comes after several years of not having an issue ever).

You mentioned it was a dupe bookmark (not parallel checks/syncs on multiple browsers/profile right?) so I have run the deduper provided with SuperSorter extension and tried again to sync and yes I am having the same issue on Windows/chrome.

Now, I have now got several dozens of bookmarks cached (ready to upload) and several hundred lost since the original post date. Given the fact I have several thousand bookmarks, it is not realistic for me to find out exactly which ones haven't been synced and which ones have. How can I fix this without losing the ones it's trying to save?

I have disabled the SuperSorter extension in preparation for whatever advice you can offer, and can turn it back on after we solve this.

I can't live without xmarks!
Thanks again for your help Dimitri.
lwb
 
Posts: 4
Joined: Fri Jan 30, 2015 2:58 pm

Re: Chromium Linux Xmarks

Postby dmitrijLP » Sat Feb 21, 2015 8:17 am

Seems like exactly the same issue, as basically what is happening is that from your local workstation to many connections are sent to the server and that results in read only access.

Please open a new support ticket with the forum link, so a developer could check your Xmarks logs on Monday:

https://lastpass.com/supportticket.php?lpnorefresh=1
dmitrijLP
 
Posts: 1332
Joined: Mon Jun 23, 2014 8:46 am

Re: Chromium Linux Xmarks

Postby lwb » Sat Feb 21, 2015 8:26 am

Thanks a lot again Dmitri :)
Done.
lwb
 
Posts: 4
Joined: Fri Jan 30, 2015 2:58 pm


Return to Xmarks

Who is online

Users browsing this forum: No registered users and 4 guests