06 - 15% CPU activity while idle

Get first access to testing new builds and betas for LastPass

Moderators: admin, anatoly_LP, chantieLP, JoeSiegrist, robyn

06 - 15% CPU activity while idle

Postby yllwsmly » Mon Jan 18, 2010 3:29 pm

Hello there,

I'm having a issue with LastPass for Applications 1.64.4 (Jan. 17th, 2009 build). When idle, there is 06 - 15% CPU activity. Is there anything I can do to assist in getting information to help you troubleshoot this issue?

Thanks,

Jeremie
yllwsmly
 
Posts: 8
Joined: Thu May 07, 2009 5:09 pm

Re: 06 - 15% CPU activity while idle

Postby bob » Mon Jan 18, 2010 7:02 pm

I am having trouble reproducing this. Some more information might help:

-Does it go away when you close lastapp (I just need to make sure ;) )
-Are you just using task manager to see this or some other tool?
-Is this increased activity attributed to lastapp.exe or it is system-wide or attributed to a different exe?

We made a performance fix today, but I am not sure if it will help with idle. You may want to give it a shot though:
https://rodan.lastpass.com/dev/lastappinstall.exe

Bob
bob
 
Posts: 243
Joined: Tue Aug 19, 2008 9:47 pm

Re: 06 - 15% CPU activity while idle

Postby yllwsmly » Mon Jan 18, 2010 7:26 pm

Thanks for your response Bob! :)

I am only using Task Manager to view the process named lastapp.exe, and the CPU utilization clearly goes away when I close LastPass from the system tray (I am able to verify that lastapp.exe goes away as well). Here is a screenshot of my Task Manager:

Image
http://3.ly/RrH

As you can see, the increased activity is directly attributed to lastapp.exe, and as well it's constant; it doesn't go away.

Another issue is that while the LastPass for Apps program is running, my mouse graphic refresh gets "snagged" about two times a second as I pull it slowly across the screen. I first noticed this issue when I was editing a picture and the mouse movement wasn't cooperating. I know that sometimes a mouse graphic refresh issue can be directly tied to high CPU activity or periodic spikes in CPU activity. So I checked Task Manager and found that the LastPass program was maintaining 6 - 15% utilization while idle. I closed it, tried dragging the mouse again, and found the issue promptly went away.

I hope this extra info helps. I am very willing to assist with any debugs in any way or give any other info your request to help solve this. Thanks!
yllwsmly
 
Posts: 8
Joined: Thu May 07, 2009 5:09 pm

Re: 06 - 15% CPU activity while idle

Postby yllwsmly » Mon Jan 18, 2010 7:35 pm

I installed the version you sent me a link for and the issue, for now, seems to have gone away. After uninstalling the older version, and running the newer install, the file lastapphook.dll was locked. I used a program called "Unlocker" to have a couple of programs (ATI CLI and Chrome) release the file. Afterwards, the install continued without issue.

I'll let it run for a while and a notify of you any change.

Thanks!
yllwsmly
 
Posts: 8
Joined: Thu May 07, 2009 5:09 pm

Re: 06 - 15% CPU activity while idle

Postby bob » Mon Jan 18, 2010 10:17 pm

Great, thanks for the follow-up,
bob
 
Posts: 243
Joined: Tue Aug 19, 2008 9:47 pm

Re: 06 - 15% CPU activity while idle

Postby yllwsmly » Tue Jan 19, 2010 12:34 pm

Bob, the new file worked. Whatever changes were in it seemed to have quashed this bug.

Thanks for the help!
yllwsmly
 
Posts: 8
Joined: Thu May 07, 2009 5:09 pm


Return to LastPass PreBuild & Beta

Who is online

Users browsing this forum: No registered users and 1 guest