LastPass Plug-In Problems with Chrome 4.0.237.0

Get first access to testing new builds and betas for LastPass

Moderators: admin, anatoly_LP, chantieLP, JoeSiegrist, robyn

LastPass Plug-In Problems with Chrome 4.0.237.0

Postby rmiller1959 » Fri Nov 13, 2009 10:39 am

Good morning,

I'm running the LastPass 1.60.0 extension with Chrome Dev Build 4.0.237.0. The extension is crashing frequently under this latest build, and I wanted to know if you're aware of it so a fix can be developed if possible. I recognize that Chrome will potentially break these extensions as it updates, so it's not a show-stopper for me. I just didn't know where else to report bugs. I hope this is the right place. Thanks!
rmiller1959
 
Posts: 1
Joined: Wed Feb 25, 2009 6:35 pm

Re: LastPass Plug-In Problems with Chrome 4.0.237.0

Postby JoeSiegrist » Fri Nov 13, 2009 10:48 am

rmiller1959 Wrote:I'm running the LastPass 1.60.0 extension with Chrome Dev Build 4.0.237.0. The extension is crashing frequently under this latest build, and I wanted to know if you're aware of it so a fix can be developed if possible. I recognize that Chrome will potentially break these extensions as it updates, so it's not a show-stopper for me. I just didn't know where else to report bugs. I hope this is the right place. Thanks!


All crashing bugs are Google's issue. If you can find a reproducible issue that's not already covered http://code.google.com/p/chromium/issues/list definitely add an issue there, and feel free to post here as we'll follow the issue and help debug it. Thanks!
JoeSiegrist
 
Posts: 4185
Joined: Wed Aug 20, 2008 10:40 am

Re: LastPass Plug-In Problems with Chrome 4.0.245.0

Postby Mortal2God » Sat Nov 14, 2009 7:59 am

Hello LastPass Team

First I would like to thank you for providing us with this great extension. I would just like to point out some problems.

The extension in Chrome works perfectly most of the time but I noticed a few problems in some websites. I am using the latest Chrome Dev build but I know the problem exists for some time now.

How do I know the problem is with the LastPass extension? Simple If I disable it the website works as it should. Let me explain. I don't really know the technical details but I think it has to do with javascript or something.

I will give you two example websites to try and let me know what you think.

http://www.eastcoast.co.uk/ This is a website for booking train tickets in the UK. Try to put two destinations and just change the dates to valid ones to make the search button available, then click on it
you will see that the website refuses to continue. Then try to disable the lastpass extension and you will see that the website takes you to the search reults if you try again.

Another one is from a university website that my friend attends to and I noticed another problem I would like you to see

try the following website

https://blackboard.tees.ac.uk/webapps/login/

Just put any logins and password, Lastpass will ask to save but the website will say

No authentication credentials were provided with the request. JavaScript must be enabled in your browser. As if the website didnt recognize any of the input

Again the website works fine once the extension is disabled.

Thanks for listening and I hope I am wrong and there is a solution for those and other similar websites that seem to be Java related, or at least help you towards solving a problem.

PS: Also what about filling forms is that feature supported yet? I know you may go through the settings but Lastpass does not recognize forms in sites automatically and request to fill it for you!
Mortal2God
 
Posts: 2
Joined: Fri Nov 13, 2009 9:10 pm

Re: LastPass Plug-In Problems with Chrome 4.0.245.0

Postby drew » Sun Nov 15, 2009 7:20 pm

Mortal2God Wrote:http://www.eastcoast.co.uk/ This is a website for booking train tickets in the UK. Try to put two destinations and just change the dates to valid ones to make the search button available, then click on it
you will see that the website refuses to continue. Then try to disable the lastpass extension and you will see that the website takes you to the search reults if you try again.


I was able to reproduce this, and I believe it's fixed in:

https://rodan.lastpass.com/lpchromepre.crx

Since this pre-build has the same version number as the current release build (1.60.0), you'll probably have to uninstall the extension before installing the pre-build.

Mortal2God Wrote:Another one is from a university website that my friend attends to and I noticed another problem I would like you to see

try the following website

https://blackboard.tees.ac.uk/webapps/login/

Just put any logins and password, Lastpass will ask to save but the website will say

No authentication credentials were provided with the request. JavaScript must be enabled in your browser. As if the website didnt recognize any of the input

Again the website works fine once the extension is disabled.


I wasn't able to reproduce this, but I didn't try until after I fixed the previous one, so perhaps they were related. Give it another shot in the pre-build.

Mortal2God Wrote:PS: Also what about filling forms is that feature supported yet? I know you may go through the settings but Lastpass does not recognize forms in sites automatically and request to fill it for you!


You're correct that we don't currently request to fill, mostly because we don't have access to the Chrome notification bar yet. You can fill manually via the bottom of the menu.

Drew
drew
 
Posts: 1081
Joined: Tue Aug 19, 2008 5:47 pm
Location: Washington, DC USA

Re: LastPass Plug-In Problems with Chrome 4.0.237.0

Postby Mortal2God » Sun Nov 15, 2009 8:15 pm

Hello Drew

Firstly I would like to thank you for the quick reply!

I am pleased to inform you that both problems have been resolved after uninstalling and installing the pre-build like you told me!

Thank you very much for letting me know!

Keep up the good work with the extension and I really like what you are doing with the chrome one (button announcements) and I cant wait to see what else you will come up with!

Thanks once more!

PS: Is there a specific site to download lastpass chrome extension updates?
Mortal2God
 
Posts: 2
Joined: Fri Nov 13, 2009 9:10 pm

Re: LastPass Plug-In Problems with Chrome 4.0.237.0

Postby drew » Mon Nov 16, 2009 9:48 am

Extensions should update automatically... But you can also go to Wrench -> Extensions and click Update Extensions Now.

Drew
drew
 
Posts: 1081
Joined: Tue Aug 19, 2008 5:47 pm
Location: Washington, DC USA

Re: LastPass Plug-In Problems with Chrome 4.0.237.0

Postby benicemi » Sat Nov 28, 2009 12:59 pm

I encountered the same problem with the latest version (4.0.237.0). No dropdown menu text is visible. I don’t really know what is happening to it. All drop-down menus went blank, but they are still working through. I guess they are just temporary bugs of the latest version. I was told to download the plugin again and luckily they are now working fine.


_________________
Multivariate Testing
benicemi
 
Posts: 1
Joined: Sat Nov 28, 2009 11:58 am


Return to LastPass PreBuild & Beta

Who is online

Users browsing this forum: No registered users and 1 guest