Autofill not working at all on some sites

A list of problematic websites and workarounds to make them work

Moderators: admin, anatoly_LP, chantieLP, JoeSiegrist, robyn

Autofill not working at all on some sites

Postby cwr64 » Mon Nov 05, 2018 3:46 pm

I've noticed that for an increasing number of sites, that LastPass will not fill in the login fields. Mostly using Current Chrome and Current Firefox on W10 desktop PC. If I enter the userid and password from the LP vault manually into the site's login pop-up screen fields, I can login OK.
ShopMyExchange.com for example... no LP icon appears in login fields. If I then right-click in one of those login fields and select LP and then Auto Fill and then the LP vault displays the site I want and I select it, expecting the LP data to be auto-filled into the site's userid and password fields - but nothing happens..
Is there a way to make LP fill in my uid & pwd into the site's login fields? I'm betting this is a common problem.
cwr64
 
Posts: 16
Joined: Thu Mar 27, 2014 4:50 pm

Re: Autofill not working at all on some sites

Postby brian324 » Fri Nov 09, 2018 6:31 am

Yes, I'm finding this is an increasing problem, not just with logins but filling in CC details etc also, to the point where it's getting really annoying. Latest FF on Win 10.

latest issue is with www.smythstoys.com
brian324
 
Posts: 3
Joined: Tue Nov 26, 2013 6:52 am

Re: Autofill not working at all on some sites

Postby HPG » Sat Nov 10, 2018 1:29 pm

I'm finding this too, particularly on Firefox. As brian324 says, it's getting really annoying.
HPG
 
Posts: 5
Joined: Sun Sep 12, 2010 8:10 am

Re: Autofill not working at all on some sites

Postby DavidBeav » Mon Nov 19, 2018 4:33 pm

In defense of LastPass, my perception is that 90% of this problem is in the lap of the web page programmers, who keep trying tricky stuff to put input fields on a page, rather than just using HTML Input fields. Although I suppose the programmers are trying to make things harder for automated bots to hack, and they don't want to test their latest technique with every password manager/browser/OS combination. So I guess it's just an arms race.
DavidBeav
 
Posts: 8
Joined: Mon Apr 23, 2018 8:54 pm

Re: Autofill not working at all on some sites

Postby YannisDran » Fri Nov 23, 2018 5:13 am

DavidBeav Wrote:In defense of LastPass, my perception is that 90% of this problem is in the lap of the web page programmers, who keep trying tricky stuff to put input fields on a page, rather than just using HTML Input fields. Although I suppose the programmers are trying to make things harder for automated bots to hack, and they don't want to test their latest technique with every password manager/browser/OS combination. So I guess it's just an arms race.


Even as it is, LastPass could provide a form for submitting such sites with "tricky" forms to amend the problems. I am not a programmer but I have some knowledge, and I know that in most of cases these problems could be tackled as most of "tricky" (scaring) tricks are similar to each other and doesn't need such an effort to re-invent the wheel.

On the other hand, the LastPass as a product cannot fail in this field while other competitors have solved or are solving this.
YannisDran
 
Posts: 7
Joined: Thu Feb 04, 2016 4:39 am

Re: Autofill not working at all on some sites

Postby lnicholsen115 » Sat Dec 15, 2018 10:59 am

I’m unable to launch a site and have user name and pa fill in, what good Is LAST PASS if it won’t meet the need?
lnicholsen115
 
Posts: 1
Joined: Sun Dec 02, 2018 9:36 pm

Re: Autofill not working at all on some sites

Postby nico536 » Sun Jan 13, 2019 8:15 pm

Any solution yet, very quite on the LP front
nico536
 
Posts: 2
Joined: Sat Dec 05, 2015 5:05 am

Re: Autofill not working at all on some sites

Postby jpenny84 » Sun Jan 13, 2019 9:34 pm

nico536 Wrote:Any solution yet, very quite on the LP front


This is primarily a user to user support forum. There's already a knowledge base article with troubleshooting steps for sites that the extension isn't filling.

https://lastpass.com/support.php?cmd=showfaq&id=7746
jpenny84
 
Posts: 8327
Joined: Tue Mar 06, 2012 9:10 pm

Re: Autofill not working at all on some sites

Postby adyro9 » Sun Jan 20, 2019 2:17 am

DavidBeav Wrote:In defense of LastPass, my perception is that 90% of this problem is in the lap of the web page programmers, who keep trying tricky stuff to put input fields on a page, rather than just using HTML Input fields. Although I suppose the programmers are trying to make things harder for automated bots to hack, and they don't want to test their latest technique with every password manager/browser/OS combination. So I guess it's just an arms race.


With HTML 5's new features (around for a few years already) like web components and shadow dom, LP's team must move forward, or provide some solution to this growing problem.
adyro9
 
Posts: 2
Joined: Tue Jan 15, 2019 3:21 pm

Re: Autofill not working at all on some sites

Postby nd3456789 » Wed Mar 13, 2019 9:48 am

Preferences>Advanced>UNCHECK "Respect AutoComplete=off..."
nd3456789
 
Posts: 2
Joined: Fri Aug 14, 2015 8:47 am


Return to Workarounds For Problematic Logins

Who is online

Users browsing this forum: No registered users and 11 guests