NatWest dead now - what is going on?

A list of problematic websites and workarounds to make them work

Moderators: admin, anatoly_LP, chantieLP, JoeSiegrist, robyn

NatWest dead now - what is going on?

Postby Julian » Mon Oct 19, 2009 5:45 am

30 minutes ago LastPass was working perfectly with this site: https://www.nwolb.com. I now come back to my PC and it's just like HSBC, LastPass doesn't highlight the Customer Number field and won't login for me. If I right-click in the box and go to Autofill on the context menu then LastPass presents me with the two vault records that should match this site so it seems to be recognising where it is to some degree but if I select one of the vault records then LastPass won't enter the data into the field (again, exactly the behaviour I get on the days where HSBC doesn't work). LastPass still seems to work as expected with other sites such as Google Mail.

What on earth is going on here? This is getting really frustrating, especially as it seems to be some of my more important sites that LastPass is suffering amnesia with.

- Julian
Julian
 
Posts: 189
Joined: Thu Nov 27, 2008 5:48 pm

Re: NatWest dead now - what is going on?

Postby JoeSiegrist » Wed Oct 21, 2009 3:00 pm

Julian Wrote:What on earth is going on here? This is getting really frustrating, especially as it seems to be some of my more important sites that LastPass is suffering amnesia with.


There's got to be a logical explanation here -- your data is still in LastPass and it's still correct, it's just not filling correct? Typically I'd say the page changed the field names but I haven't been able to see that happen with your UK HSBC site.
JoeSiegrist
 
Posts: 4185
Joined: Wed Aug 20, 2008 10:40 am

Re: NatWest dead now - what is going on?

Postby flippertie » Sun Oct 25, 2009 8:31 am

When I looked into the HSBC site I found it was assigining a session ID which forms part of the URL for the page where I enter the first data. This means in effect that the page address changes each time you visit it. Can you see if the NatWest page does something similar?

I posted a sample of the URL in the HSBC thread.

I'm guessing that is part of the problem - but it is odd that LastPass will sometimes recognise the field, and miss it at others.
flippertie
 
Posts: 26
Joined: Sun Oct 11, 2009 3:02 am

Re: NatWest dead now - what is going on?

Postby Julian » Sun Oct 25, 2009 10:55 am

Thanks flippertie. I saw your HSBC post.

LastPass staff have been a bit more active on my problem than it might appear from the forums. I emailed my issues to them directly and have had some email interactions with Joe. It's turned out that this NatWest problem is to do with the fact that NatWest changed the name of the field itself on the login page so when I recreated my NatWest records the new versions picked up the new field name and work OK.

The HSBC one is still a bit of a mystery though. I discovered with HSBC as well that, if I recreate my login record, the new record works and the old one still doesn't. I emailed Joe the basic details of my old (not-working) and new (working) records for HSBC; I didn't of course give him my login details, just the URL that LastPass had stored in each case and the field name it had stored. The field name was identical in both records and, from looking at the two URLs, Joe seemed to think that the LastPass URL matching algorithm is flexible enough that it knows to ignore stuff like the session ID at the end and should have matched both records.

Anyway, now that my newly-created records work I plan to just delete the old ones and move on but, for HSBC at least, there does still seem to be a mystery being left unsolved here. It's also really weird coincidence (but I'm sure it is just a coincidence) that it was my accounts on two of the biggest but totally unconnected UK mega-banks that went wrong within days of each other.

- Julian
Julian
 
Posts: 189
Joined: Thu Nov 27, 2008 5:48 pm

Re: NatWest dead now - what is going on?

Postby flippertie » Mon Oct 26, 2009 5:22 am

It's also really weird coincidence (but I'm sure it is just a coincidence) that it was my accounts on two of the biggest but totally unconnected UK mega-banks that went wrong within days of each other.


Of course it's just a coincidence. And neither of us really believe that 'they' (you know who I mean) have any influence or existence at all......
flippertie
 
Posts: 26
Joined: Sun Oct 11, 2009 3:02 am

Re: NatWest dead now - what is going on?

Postby JoeSiegrist » Mon Oct 26, 2009 11:25 am

I think I know what's going on here -- if you use 'Save All Entered Data' we treat it as needing a stronger URL match than a typical site, but HSBC's URL is changing causing us to not fill.
JoeSiegrist
 
Posts: 4185
Joined: Wed Aug 20, 2008 10:40 am

Re: NatWest dead now - what is going on?

Postby flippertie » Wed Oct 28, 2009 12:03 pm

Thanks. That makes sense. But for that page we have to use 'Save all Entered Data' because LastPass won't pick it up automatically.

Is there a work around?
flippertie
 
Posts: 26
Joined: Sun Oct 11, 2009 3:02 am

Re: NatWest dead now - what is going on?

Postby JoeSiegrist » Thu Oct 29, 2009 12:40 am

flippertie Wrote:Thanks. That makes sense. But for that page we have to use 'Save all Entered Data' because LastPass won't pick it up automatically.

Is there a work around?


You can use a '*' in the URL but that'll break launching -- we realize we have to make some changes here which we're going to start working on now...
JoeSiegrist
 
Posts: 4185
Joined: Wed Aug 20, 2008 10:40 am

Re: NatWest dead now - what is going on?

Postby flippertie » Fri Oct 30, 2009 10:17 am

Thanks for letting us know. I look forward to the solution in due course. In the mean time I can manage one manual login myself. I think....
flippertie
 
Posts: 26
Joined: Sun Oct 11, 2009 3:02 am


Return to Workarounds For Problematic Logins

Who is online

Users browsing this forum: No registered users and 15 guests