LastPass in IE9

Have questions about LastPass, or having problems using it? Ask for help here!

Moderators: admin, Israel, anatoly_LP, chantie, robyn, JoeSiegrist

LastPass in IE9

Postby borekb » Wed Sep 21, 2011 8:48 am

OK I've been frustrated with how LastPass works / doesn't work in IE9. I tried searching FAQs and forums but I figured I'd rather create a new topic so there you go..

I'm looking for a concise guide on how to set up LastPass in IE9 to be unobtrusive (like it is in Firefox or Chrome).

By default, LastPass shows a toolbar with only one button - a waste of space. When I try to close the toolbar, using the "x" button on the toolbar itself or by unticking the LastPass Toolbar in the toolbars menu, I am shown the window "Do you want to disable this add-on" with two check boxes, "LastPass Browser Helper Object" and "LastPass". This is confusing and I don't know whether to keep the checkboxes checked or not. I only wanted to hide the toolbar, not to disable LastPass completely so I cancelled this window.

Then I went to LastPass preferences and on the General tab, I selected something like "Use command button only". I was prompted to restart the browser which I did. The toolbar was gone but the functionality was still there (after visiting a site with fillable form, yellow bar appeared at the top of the frame with "autofill", "autologin" etc. options). So far so good but how can I now display the toolbar again? How can I access settings? I cannot see any new button in the "command bar", disabling and re-enabling LastPass in Addons Manager has no effect etc.

I am confused with how LastPass is intended to work best in IE. Support pages mention command button but that doesn't show up in IE9. They reference LastPass settings but how do I access them when the toolbar is hidden? I'd be grateful if someone could clear things up for me.

Thanks,
Borek
borekb
 
Posts: 8
Joined: Fri Dec 04, 2009 12:55 pm

Re: LastPass in IE9

Postby $bill » Wed Sep 21, 2011 5:27 pm

Hint- display the command bar (Alt | View | Toolbars)
right click on the command bar and choose customize | add remove commands and add the Lastpass button

Pasting from my previous post:

My current approach to avoid the wasted space and poor visual appearance:

Lastpass - use only command bar button
Remove all the buttons except Lastpass from the command bar and display it.
Also display the favorites bar on the same line as the command bar and fill with some useful bookmarks.
Size the bars so that the Lastpass button in at the right margin of the browser.

Hint- right click on the command bar and choose customize | add remove commands
$bill
 
Posts: 55
Joined: Sun Feb 13, 2011 10:04 pm

Re: LastPass in IE9

Postby DavidPaul » Wed Jan 25, 2012 9:53 pm

I'm having the same problem. When I right-click the command (menu?) bar, I don't see any "Customise":
Untitled.jpg

Any ideas?
DavidPaul
 
Posts: 4
Joined: Fri Oct 15, 2010 12:30 am
Location: New Zealand

Re: LastPass in IE9

Postby $bill » Thu Jan 26, 2012 12:08 pm

It is not the Menu bar that you want to customise, it is the Command bar. Your picture does not have a check mark by the Command bar, so it is not being displayed in IE.
First thing is to display the command bar (menu >> View | Toolbar | Check Command bar) which will be located on upper-right side of the window. Now right click on the Command bar to find Customize.
$bill
 
Posts: 55
Joined: Sun Feb 13, 2011 10:04 pm

Re: LastPass in IE9

Postby kilgry » Thu Jan 26, 2012 12:55 pm

First of all, I agree. It would be nice if LP could better integrate with IE9 (appear next to the home/fav/tools icons), but the dev staff says MS hasn't opened IE9 that far yet. What I do instead is use the "Compact toolbar" option in LP and then unlock the toolbars in IE9. Finally I move the menu bar (now set to display) up to and next to the LastPass Toolbar and relock the toolbars in IE9.
kilgry
 
Posts: 817
Joined: Sun Feb 13, 2011 5:41 pm

Re: LastPass in IE9

Postby DavidPaul » Thu Jan 26, 2012 6:02 pm

Ah, there it is, hiding in plain sight! Thanks for your help.
DavidPaul
 
Posts: 4
Joined: Fri Oct 15, 2010 12:30 am
Location: New Zealand


Return to General Support & Troubleshooting

Who is online

Users browsing this forum: leonalewis176196, marcus and 16 guests