Random High CPU Usage in Edge Chromium

Have questions about LastPass, or having problems using it? Ask for help here!

Moderators: admin, anatoly_LP, chantieLP, Israel, JoeSiegrist, robyn

Random High CPU Usage in Edge Chromium

Postby ITeeWeenie729 » Tue Jun 23, 2020 12:24 pm

Hi there,

Just wanted to offer a workaround for users experiencing high cpu usage in idle Edge (Chromium) browsers.

I've been using LastPass for years, and I am familiar with the fact that it can be quite buggy at times, but It's value to me still far outweighs it's pain.

In January of 2020, I switched from using Firefox for Windows to Google's Chrome for my primary browser, mainly due to performance issues with Firefox in general. Shortly thereafter, I ran into my first high-cpu usage event in Chrome where it would consume 50% of the CPU just sitting idle (and with no other apps running.) After first blaming Chrome and researching-the-crap-out-of-it yet not being able to find a solution, I finally was able to determine that it was the LastPass extension being the source of the problem. Again, loads of research and trial and error, but no joy. I then removed the extension and voila! - problem solved!? Why didn't I do this earlier? - because in my mind, installing/reinstalling the extension in Firefox was hard and ugly (whether it was in reality or not) and I just assumed it would be ugly in Chrome. Anyhow, I then reinstalled the extension (which was very simple and quick) and the problem did not reappear. Yay!

Thinking that this might have been a one-off deal, I went on my merry way, for about a month. In the meanwhile, I had switched to Microsoft's Edge (Chromium) browser as my primary browser, and then bam! High CPU Usage again (from LastPass) combined with non-operational LastPass extension. Again, research, frustration, no-solution. I then removed and reinstalled the extension. Yay! Problem(s) solved again.

Since then, I have come up against either the high-cpu usage problem or non-operational extension (button does nothing, no menus, LP doesn't fill forms) about once a month - and each and every time I've solved the issues by simply removing the extension, reinstalling the extension and then logging back in - all of which takes less than one minute of my time. Now, don't get me wrong - this is clearly an issue that I would like for the developers to resolve, but for me at least, I have learned to live with the problems as this workaround is simple and quick. I don't even think about it, or frustrate myself any more - I just remove, reinstall, and continue with life. Hopefully this is of some use to those banging their heads in frustration over LastPass and its random problems.


Posts: 1
Joined: Tue Jun 23, 2020 11:10 am

Return to General Support & Troubleshooting

Who is online

Users browsing this forum: Bing [Bot] and 40 guests