Safari Extension : fields not completing

Have questions about LastPass, or having problems using it? Ask for help here!

Moderators: admin, anatoly_LP, chantieLP, Israel, JoeSiegrist, robyn

Re: Safari Extension : fields not completing

Postby PeriPLaneta » Wed Aug 08, 2018 1:23 am

I followed the instructions above and it worked (for now ...)

1. Go to https://lastpass.com/download/cdn/lastpass.safariextz
2. Download the installer
3. Uninstall the current version of LastPass (4.15.2) that refuses to work
4. Restart Safari
5. Open the installer and follow the instructions to install the old version, 4.9.037
6. Restart Safari
7. Uncheck the box in the extensions preferences that says "Automatically update extensions ..."
8. You should now have the old version installed, and it should work as before.

It has taken the LastPass developer far too long to correct this problem. It was identified at least two weeks ago. A reasonable question to ask would be, "Why should I pay for an extension that does not work?"
PeriPLaneta
 
Posts: 5
Joined: Thu Aug 02, 2018 1:44 pm

Re: Safari Extension : fields not completing

Postby gord16 » Wed Aug 08, 2018 10:26 am

gord16 Wrote:This is happening to myself as well using Safari and it also started yesterday :(
MacOS High Sierra 10.13.6 (17G65)
Safari Version 11.1.2 (13605.3.8)


Submitted a ticket August 7th, 2018 and received this response almost immediately from LastPass. They are aware and are working on it.

"Hi there,
Thank you for reaching out and apologies for any inconvenience.
We did notice inconsistencies with autofilling on Safari which our team is currently investigating and we hope to fix this in our next update for Safari. In the meantime please use the LastPass extension from a different browser to autofill and save new logins. "
gord16
 
Posts: 3
Joined: Sat Jul 28, 2018 6:29 pm

Re: Safari Extension : fields not completing

Postby KKW » Wed Aug 08, 2018 1:10 pm

grafiksol10752 Wrote:I just received further communication from LastPass Support, suggesting I download and install the Safari extension from this link:
https://lastpass.com/download/cdn/lastpass.safariextz

The installed extension is identified as Version 4.9.0.37, which after a Safari restart, seems to function properly. (That is the same extension version I was able to download a couple days ago from the "normal" LastPass download site, which now reflects a download version of 4.15.2 (which does not work).

So, as I outlined in an earlier post, "Uninstall" any currently non-working extension and install the 4.9.0.37 version and seemingly all well be fully functional once again.


THANK YOU! for that link. Removed the 4.15 extension, used your link to download and install the working 4.9 extension and I unchecked the option to automatically update the extension as you previously suggested. Now autofill works again!

But even after my support ticket was "escalated" to "level 2" they just kept telling me that downloading and reverting was not possible and that they are "profusely working hard to fix this." Completely useless support...

I am still investigating alternatives. Keeper does not enable quick search of the vault directly from within the extension, which is something I use A LOT with lastpass, so I may be crossing that off my list. However, it seems to work more consistently across a wider variety of login types, although selecting from a list of different logins for the same site takes several more clicks.
KKW
 
Posts: 4
Joined: Tue Aug 07, 2018 11:54 am

Re: Safari Extension : fields not completing

Postby gaboose990 » Thu Aug 09, 2018 9:49 am

Same problem here. No auto fill on any web sites, even when I go into the extension menu and manually choose "auto fill" there....
gaboose990
 
Posts: 2
Joined: Tue Jan 03, 2017 10:30 am

Re: Safari Extension : fields not completing

Postby KKW » Thu Aug 09, 2018 11:01 am

Yep, Safari users are being treated as second class and un-important. Nevermind that we want to use a browser that isn't constantly either trying to shill "search" (personal datamining) services to us or secretly send all of our web browsing to our corporate overlords... If we really wanted privacy we wouldn't keep our passwords in an online repository. I guess.

Get the old, stable version here:

https://lastpass.com/download/cdn/lastpass.safariextz
KKW
 
Posts: 4
Joined: Tue Aug 07, 2018 11:54 am

Re: Safari Extension : fields not completing

Postby jhaiar194 » Thu Aug 09, 2018 2:06 pm

Fields not populating for me either, does not make any difference if on a Mac using Safari or Chrome or on a PC using Edge or Chrome. Only difference for me appears to be that it is Sporadic. For example I can have Safari fail on a particular site, bring up Chrome and the site will work. Next time they will both fail
jhaiar194
 
Posts: 1
Joined: Thu Aug 09, 2018 1:55 pm

Re: Safari Extension : fields not completing

Postby robert238 » Thu Aug 09, 2018 8:51 pm

I found a workaround that has worked so far (tested on multiple sites).

Like everyone else, when I load a page with a login form using MacOS safari, the usual symbols in the form fields for last pass don't display and using the autofill command from the last pass button does not work. HOWEVER...

If I hit "command+R" (reload the page), the last pass symbols in the fields magically appear and I can autofill the login. Hopefully this works for others too.
robert238
 
Posts: 1
Joined: Thu Aug 09, 2018 8:49 pm

Last pass not working on mac

Postby Stoorsooker » Thu Aug 09, 2018 11:37 pm

Do not know if this is the correct place to post or not. LP not filling in forms on macbook. Contacted help last month, was told they know about it and are working on a fix. They cant give a time for this to happen. Anyone else having this problem as I have contacted them several times and their response was really poor?
Stoorsooker
 
Posts: 2
Joined: Fri Nov 17, 2017 8:39 pm

Re: Safari Extension : fields not completing

Postby james332 » Fri Aug 10, 2018 5:44 am

Having the same issue. Pretty fundamental to the whole point of using LastPass. May be time has come to look for a different product?
james332
 
Posts: 1
Joined: Fri Aug 10, 2018 5:43 am

Re: Safari Extension : fields not completing

Postby nhubert2674 » Fri Aug 10, 2018 9:32 am

Not sure if that helps and if there is a link with this issue... but I'm using a an AdBlock on Safari... if I disable the Adblock and relaunch the website then LP is displaying the PWD access of LP...
nhubert2674
 
Posts: 1
Joined: Fri Aug 10, 2018 9:30 am

PreviousNext

Return to General Support & Troubleshooting

Who is online

Users browsing this forum: No registered users and 62 guests