Safari Extension : fields not completing

Have questions about LastPass, or having problems using it? Ask for help here!

Moderators: admin, anatoly_LP, chantieLP, Israel, JoeSiegrist, robyn

Re: Safari Extension : fields not completing

Postby MisterToad » Wed Aug 01, 2018 12:24 pm

Iason Wrote:I had the issue and I recognized it because I was tasked with disable password managers years ago. There's an HTML setting ("autocomplete=off") to disable autofilling form fields and it works on all form including usernames and passwords. Nearly every browser ignores it for usernames and passwords. It looks like LastPass also ignored until a recent update. Here's how to change it:

[*]Check the Respect AutoComplete=off: allow websites to disable AutoFill box. It looks like the label is incorrect.


Nice try, but didn't work for me. Contacted support, who wanted me to reinstall the (older) extension here: https://lastpass.com/misc_download2.php

That one wouldn't install at all. "Safari can't install this extension. An error occurred while installing the extension "LastPass"."

Stuck...
MisterToad
 
Posts: 1
Joined: Wed Aug 01, 2018 12:15 pm

Re: Safari Extension : fields not completing

Postby samtherobot » Wed Aug 01, 2018 1:07 pm

Jason's solution sort of worked for me. When I went into the preferences the option was not checked (which seems correct). I checked the box and saved but it still did not fix the issue. So I went back to the preferences and unchecked the same option, saved, and then it began working.

My only thought was somehow my preferences became corrupted and what was showing up on my preferences screen was not actually how the extension was functioning. Hopefully that helps others.


I had the issue and I recognized it because I was tasked with disable password managers years ago. There's an HTML setting ("autocomplete=off") to disable autofilling form fields and it works on all form including usernames and passwords. Nearly every browser ignores it for usernames and passwords. It looks like LastPass also ignored until a recent update. Here's how to change it:

Open up LastPass preferences (for example, click the LastPass icon next to the Address Bar and select Preferences from the drop down menu..
Click the Advanced tab on the left.
Check the Respect AutoComplete=off: allow websites to disable AutoFill box. It looks like the label is incorrect.
Click the Save button at the bottom of the page.
Reload any page that you have open that LastPass isn't autofilling or the icon isn't appearing in the username and password fields.

This procedure solved the issue for me.

EDIT: Double-checked my settings and I had to turn the setting on — it looks like the check box says the opposite of what it does.
samtherobot
 
Posts: 2
Joined: Wed Aug 01, 2018 1:04 pm

Re: Safari Extension : fields not completing

Postby wheresmyjet747 » Wed Aug 01, 2018 3:55 pm

I'm having the same problem here. This needs to be fixed, its very irritating and makes Last Pass unusable to me. Thanks in advance for fixing this quickly.
wheresmyjet747
 
Posts: 1
Joined: Wed Aug 01, 2018 3:52 pm

Re: Safari Extension : fields not completing

Postby warseph » Wed Aug 01, 2018 4:42 pm

I had the same issue, I fixed it by enabling the option "Enable infield popup" in Preferences > Advanced. I don't know if this is a new option or if some update deselected it by default.
warseph
 
Posts: 1
Joined: Wed Aug 01, 2018 4:41 pm

Re: Safari Extension : fields not completing

Postby samtherobot » Wed Aug 01, 2018 4:46 pm

Spoke too soon. Apparently that wasn't a permanent fix as now my autofill is not working again.

samtherobot Wrote:Jason's solution sort of worked for me. When I went into the preferences the option was not checked (which seems correct). I checked the box and saved but it still did not fix the issue. So I went back to the preferences and unchecked the same option, saved, and then it began working.

My only thought was somehow my preferences became corrupted and what was showing up on my preferences screen was not actually how the extension was functioning. Hopefully that helps others.


I had the issue and I recognized it because I was tasked with disable password managers years ago. There's an HTML setting ("autocomplete=off") to disable autofilling form fields and it works on all form including usernames and passwords. Nearly every browser ignores it for usernames and passwords. It looks like LastPass also ignored until a recent update. Here's how to change it:

Open up LastPass preferences (for example, click the LastPass icon next to the Address Bar and select Preferences from the drop down menu..
Click the Advanced tab on the left.
Check the Respect AutoComplete=off: allow websites to disable AutoFill box. It looks like the label is incorrect.
Click the Save button at the bottom of the page.
Reload any page that you have open that LastPass isn't autofilling or the icon isn't appearing in the username and password fields.

This procedure solved the issue for me.

EDIT: Double-checked my settings and I had to turn the setting on — it looks like the check box says the opposite of what it does.
samtherobot
 
Posts: 2
Joined: Wed Aug 01, 2018 1:04 pm

Re: Safari Extension : fields not completing

Postby nhw » Wed Aug 01, 2018 5:07 pm

MisterToad Wrote:Nice try, but didn't work for me. Contacted support, who wanted me to reinstall the (older) extension here: https://lastpass.com/misc_download2.php

That one wouldn't install at all. "Safari can't install this extension. An error occurred while installing the extension "LastPass"."

Stuck...


I uninstalled the extension from the Safari -> Preferences -> Extensions tab, then installed the one from the link above; works now for me; seems like some kind of disastrous regression in the newer version.
nhw
 
Posts: 3
Joined: Tue Jul 31, 2018 1:31 am

Re: Safari Extension : fields not completing

Postby ilariap » Wed Aug 01, 2018 9:22 pm

Same here. Uninstalled latest version and reinstalled 4.9.0.37 and it works.
ilariap
 
Posts: 3
Joined: Wed Aug 01, 2018 8:54 pm

Re: Safari Extension : fields not completing

Postby ARARAR » Wed Aug 01, 2018 9:38 pm

Same thing happening to me - virtually no fields being auto filled in Safari as of around a week ago. Frustrating.
ARARAR
 
Posts: 1
Joined: Wed Aug 01, 2018 9:36 pm

Re: Safari Extension : fields not completing

Postby jimbob92 » Wed Aug 01, 2018 10:14 pm

Downgrading to 4.9.0 worked for me too... Gross.
jimbob92
 
Posts: 2
Joined: Tue Jul 31, 2018 5:54 pm

Re: Safari Extension : fields not completing

Postby mlevison » Thu Aug 02, 2018 9:42 am

I was rather hoping to find an official acknowledgement from lastpass along with a comment like hang tight a fix is coming.

I really don't like manual workarounds like downgrading. Time to move to Chrome for a while.

Cheers
Mark
mlevison
 
Posts: 1
Joined: Tue Jan 04, 2011 10:21 pm

PreviousNext

Return to General Support & Troubleshooting

Who is online

Users browsing this forum: Exabot [Bot], Google Feedfetcher, sanctempdyra712 and 63 guests