KeePass Import Failed

Have questions about LastPass, or having problems using it? Ask for help here!

Moderators: admin, Israel, anatoly_LP, chantie, robyn, JoeSiegrist

KeePass Import Failed

Postby djatnieks » Sat Feb 21, 2009 12:04 am

I am unable to import from KeePass - everything appears to go okay, until the end - then it just says "import failed"

I have tried both the web page import (both IE and Firefox) and the lastpass.exe import.

From the import form:
Found 279 sites.

Encrypting 274 of 279 : xxxxxxx
Encrypting 275 of 279 : xxxxxxx
Importing 25 sites.......
Encrypting 276 of 279 : xxxxxxx
Encrypting 277 of 279 : xxxxxxx
Encrypting 278 of 279 : xxxxxxx
Encrypting 279 of 279 : xxxxxxx
Importing 4 sites...Error!

The start of my KeePass.xml file looks like this
<?xml version="1.0" encoding="utf-8" standalone="yes"?>
<KeePassFile>
...


p.s. It's ironic that signing up for this message board results in sending me an email with my password in cleartext!
djatnieks
 
Posts: 8
Joined: Fri Feb 20, 2009 11:55 pm

Re: KeePass Import Failed

Postby djatnieks » Sat Feb 21, 2009 12:12 am

After logging out of lastpass and logging in again, I find that the import actually did work, and 4 times at that. I don't know what that error message I received means, but it _seems_ like it actually worked. I'm not about to count all 279*4 entries to see if any are missing or not so I'll just hope they are there. I also hope I can remove duplicates easily.
djatnieks
 
Posts: 8
Joined: Fri Feb 20, 2009 11:55 pm

Re: KeePass Import Failed

Postby bob » Sat Feb 21, 2009 4:34 pm

I think this problem is fixed, thanks for reporting it.

Some of your accounts may not have been imported, so you may want to remove all sites (easily done by opening the Vault page, selecting all by clicking on top site and then holding shift and clicking on the bottom site. Then right click and choose Delete Selected).

Then reimport.

If you do not want to delete, we do have a deduplicator tool if you hit Account Settings from the Vault, you should see a tab for it.

Let us know if you experience any other problems.
Thanks
Bob
bob
 
Posts: 232
Joined: Tue Aug 19, 2008 9:47 pm

Re: KeePass Import Failed

Postby djatnieks » Wed Apr 01, 2009 9:15 pm

Thanks.

I did run the deduplicator and have been using lastpass with good success since that time.

I have now noticed, however, that some of my KeePass entries were not correctly imported after all. I don't know if has something to do with the original problem I reported or something else, but here is the issue:

It appears that entries I had in KeePass which included something in the "Notes" section were imported to lastpass as a Secure Note _only_. The user/password info never got imported.

Is there anything I can do about this? I really don't want to go back and review every entry manually ... :( And I don't want to start over, because lastpass now has the latest information and updates.

Thanks
djatnieks
 
Posts: 8
Joined: Fri Feb 20, 2009 11:55 pm

Re: KeePass Import Failed

Postby JoeSiegrist » Wed Apr 01, 2009 11:04 pm

If you can sort your exported keypass data by URL, I'd be willing to bet it's on the the sites without URLs associated with them in Keepass that were problematic -- if we see notes but no URL we push the notes path (though it looks like we need to be more nuanced about it).
JoeSiegrist
 
Posts: 4144
Joined: Wed Aug 20, 2008 10:40 am

Re: KeePass Import Failed

Postby djatnieks » Thu Apr 02, 2009 12:07 pm

Yes, that could be the case - I can't sort, but I did spot check the xml file and the entries I know about don't have a URL but do have notes.

I would suggest that if there is a user/password you always create a site entry. I have a lot of entries that never had a URL - maybe because I have migrated from Whisper to KeePass and now to lastpass.

What do you suggest I do? If you change the behaviour of import a little, I could wait for that and then re-import my entries and de-duplicate them. Does that sound like an approach that will work?
djatnieks
 
Posts: 8
Joined: Fri Feb 20, 2009 11:55 pm

Re: KeePass Import Failed

Postby djatnieks » Wed Apr 08, 2009 1:37 pm

Any advice from my previous post? Just pinging ....
djatnieks
 
Posts: 8
Joined: Fri Feb 20, 2009 11:55 pm

Re: KeePass Import Failed

Postby JoeSiegrist » Wed Apr 08, 2009 1:55 pm

We now allow you to import sites without URLs so I'd reimport the list and then only check the sites without URLs to import....
JoeSiegrist
 
Posts: 4144
Joined: Wed Aug 20, 2008 10:40 am

Re: KeePass Import Failed

Postby djatnieks » Wed Apr 08, 2009 2:14 pm

That's great, thanks for the update. I'll give it a try and report back the result.
djatnieks
 
Posts: 8
Joined: Fri Feb 20, 2009 11:55 pm

Re: KeePass Import Failed

Postby djatnieks » Fri Apr 10, 2009 12:06 am

Ok, I was trying out the import again and noticed something else - occasionally duplicate, or triple entries listed on the import page. I think it has to do with some sort of history mechanism that KeePass has. The exported xml file has something like this:
<Entry>
<History>
<Entry>
</Entry>
</History>
</Entry>

So if my entry is for FOO, then I am getting two FOO's listed on the import page and I can't tell which is the current entry and which is the "history" entry. Sorry, I don't really know KeePass well enough to know what the history entry is...

Can you ignore the <Entry> tags that are nested inside the <History> tags?

Thanks

dan
djatnieks
 
Posts: 8
Joined: Fri Feb 20, 2009 11:55 pm

Next

Return to General Support & Troubleshooting

Who is online

Users browsing this forum: Bing [Bot], geordie582, Google [Bot] and 11 guests