Plugin seems broken with new Firefox 58

Have questions about LastPass, or having problems using it? Ask for help here!

Moderators: admin, Israel, anatoly_LP, chantieLP, robyn, JoeSiegrist

Plugin seems broken with new Firefox 58

Postby unixwizzard » Wed Jan 24, 2018 5:02 pm

Firefox just pushed out version 58 - Desktop browser on Windows 10 Pro 64 bit.

Since installing version 58, every time the browser is closed while the plugin is logged into LastPass, the next start of the browser I need to re-logon to the plugin. It happens even if I close the browser and restart it immediately.

This did not happen with any of the version 57 browsers.

And yes, I have all "Automatically Log out" options disabled.

This behavior does not happen on Chrome, IE or Opera browsers. On those if I'm logged in I stay logged in.

For now I have "saved" my password as a workaround on Firefox, tho I'd rather not have that enabled.
unixwizzard
 
Posts: 5
Joined: Fri Sep 29, 2017 5:01 am

Re: Plugin seems broken with new Firefox 58

Postby unixwizzard » Wed Jan 24, 2018 5:09 pm

Now I don't even have to log out.. As I was typing the above post the icon went orange indicating my session timed out.

Is there some other setting other than the two "Automatically Log out" settings that might be causing these time outs?
unixwizzard
 
Posts: 5
Joined: Fri Sep 29, 2017 5:01 am

Re: Plugin seems broken with new Firefox 58

Postby cbrillow » Wed Jan 24, 2018 7:32 pm

This did not happen with any of the version 57 browsers.
Actually, it did, although it's maddeningly inconsistent. It affected a couple of my computers with FF57, but not all of them.

I've put LP and FF out to pasture as long as they won't play nice. And LP has already lost me as a premium subscriber.
cbrillow
 
Posts: 60
Joined: Wed May 07, 2014 7:56 am

Re: Plugin seems broken with new Firefox 58

Postby JML » Thu Jan 25, 2018 8:59 am

I can't login with Firefox 58 plugin at all. Chrome login is ok.
Also login through the lastpass website is ok with Firefox 58, but the plugin login in Firefox 58 just doesn't work (plugin version 4.2.3.20)

I have tried uninstaling and re-installing the plugin countless times, but no.
JML
 
Posts: 7
Joined: Fri Dec 30, 2011 1:54 pm

Re: Plugin seems broken with new Firefox 58

Postby unixwizzard » Thu Jan 25, 2018 1:29 pm

JML Wrote:I can't login with Firefox 58 plugin at all. Chrome login is ok.
Also login through the lastpass website is ok with Firefox 58, but the plugin login in Firefox 58 just doesn't work (plugin version 4.2.3.20)

I have tried uninstaling and re-installing the plugin countless times, but no.


same here..

I did finally get it to work tho.. What I did was do a clean install of FF 58, new profile and all. Then I dumped a backup of my .AppData\Roaming\Mozilla profile from a week old backup, changed the profiles.ini to make FF use the restored profile folder.. after this, I restated FF and immediately went into plugins and ran the check for updates - one of the updates that came down was for the LastPass extension dated Jan 24th, so it looks like they just released a new version.

That fixed the problem for me. Maybe all what I did wasn't necessary, I think the updated plugin had just been released while I was working on my fix. Prior to the steps I listed above, the plugin updates was not giving me a new LP plugin. So if the new plugin doesn't solve your problem, try my steps above. If you don't have backups, then give the steps below a shot.. I've done similar with other plugins when a FF update broke one (usually it's because some plugins will pick up old/broken data even doing a remove/reinstall).

The next step is doing it the hard way.. Go through .AppData\Roaming\Mozilla\Firefox\Profiles\YourProfileName, and remove anything with "support@lastpass.com" in or as the name.. might be best to start in your .AppData directory and do a search for support@lastpass.com - just in case your directories are different, those files should be located in these directories:

browser-extension-data
extensions
jetpack
storage\permanent

Then re-install the plugin. This "hard way" I think would be a last-resort attempt to at least saving all your other FF plugins, setup, customization, since the next step would be to remove/reinstall FF, wiping the Local and Roaming Mozilla directories and starting from scratch 100% with a new profile.
unixwizzard
 
Posts: 5
Joined: Fri Sep 29, 2017 5:01 am

Re: Plugin seems broken with new Firefox 58

Postby JML » Fri Jan 26, 2018 8:50 am

I got Lastpass plugin to log in in Firefox 58, after I did a full uninstall of Lastpass from Windows Control Panel and installing the plugin again in Firefox.
JML
 
Posts: 7
Joined: Fri Dec 30, 2011 1:54 pm

Re: Plugin seems broken with new Firefox 58

Postby madLyfe » Fri Jan 26, 2018 12:02 pm

im using the binary to sync between chrome and ff and they seem to have been disconnected. i have it so when one is logged out the other is as well. now i have to manually login/out of the ff extension.
madLyfe
 
Posts: 42
Joined: Mon Mar 14, 2016 8:42 pm

Re: Plugin seems broken with new Firefox 58

Postby unixwizzard » Fri Jan 26, 2018 12:40 pm

back to the plugin not working right again.. not only does closing the browser cause me to need to log back into LP upon restart, now it's starting to log me out 5-10 minutes after I do a re-login..

I caught the plugin's icon on the browser go from Red to Black several times - no error notification either.

I guess since it's ONLY with Firefox, it's time to just stop using it since whatever agenda they're pushing seems to break shit every time there is a major version change.. upgrading from 55 -> 56 broke shit, 56 -> 57 REALLY broke shit, and it looks like 57 - > 58 is no different. maybe mozilla wants us to wipe everything and start completely from scratch ever time they release a new version.

Back to Opera for now
unixwizzard
 
Posts: 5
Joined: Fri Sep 29, 2017 5:01 am


Return to General Support & Troubleshooting

Who is online

Users browsing this forum: Google [Bot] and 73 guests