Chrome javascript error - onloadwff.js:68

Have questions about LastPass, or having problems using it? Ask for help here!

Moderators: admin, anatoly_LP, chantieLP, Israel, JoeSiegrist, robyn

Chrome javascript error - onloadwff.js:68

Postby booji » Thu Sep 28, 2017 2:34 pm

I'm getting a Javascript error from the chrome pugin on Windows.

The error is on a website I'm developing, so isn't yet publicly accessible.

It's a bootstrap 4 UI, on a modal for changing your password.

The form has three fields: old password, new password, confirm new password.

If you enter the old password incorrectly and submit, the server responds with a 403 error, and an alert is inserted into the UI.

At that point, Lastpass starts throwing this error every second or so:

Uncaught TypeError: o.val is not a function
at n (onloadwff.js:68)
at r (onloadwff.js:68)
at onloadwff.js:68

It repeats over and over, with no indication that it ever stops happening.
booji
 
Posts: 1
Joined: Thu Sep 28, 2017 2:26 pm

Re: Chrome javascript error - onloadwff.js:68

Postby che3ver » Tue Oct 03, 2017 9:45 pm

I have the exact same error, also on a site I'm developing. I'm using the chrome plugin on a Mac.

My error is happening after a successful ajax call (201) for my registration. I'm using Angular.

It doesn't seem to prevent the rest of my javascript from continuing to run.
che3ver
 
Posts: 2
Joined: Tue Oct 03, 2017 9:37 pm

Re: Chrome javascript error - onloadwff.js:68

Postby che3ver » Tue Oct 03, 2017 9:54 pm

Update: I fixed this error by renaming the ids of my fields to reg_username, reg_password, login_username, and login_password.
che3ver
 
Posts: 2
Joined: Tue Oct 03, 2017 9:37 pm

Re: Chrome javascript error - onloadwff.js:68

Postby rbrunt158 » Thu Oct 05, 2017 10:56 am

Adding a pw change to a site i'm doing and keep getting this error as well. Changed around the id's but the only thing that stops this is disabling lastpass. Also using angular.
rbrunt158
 
Posts: 1
Joined: Thu Oct 05, 2017 10:52 am

Re: Chrome javascript error - onloadwff.js:68

Postby totallyahuman » Fri Oct 06, 2017 9:19 am

che3ver Wrote:Update: I fixed this error by renaming the ids of my fields to reg_username, reg_password, login_username, and login_password.


Did you change it from reg_XYZ to login_XYZ, and that fixed the issue?

Please report this bug if you haven't already (this is just the support section). That's a pretty silly and quite annoying bug, and means that arbitrary users can end up being caught in infinite loops just because of choice of ID value. :/
totallyahuman
 
Posts: 3
Joined: Fri Oct 06, 2017 4:41 am

Re: Chrome javascript error - onloadwff.js:68

Postby Andrea » Tue Oct 31, 2017 6:43 am

Any news about it? Lastpass support team seems to ignore the bug. I'm building a very simple update password form (with Angular) where there are 3 inputs for: currentPassword, newPassword and confirmPassword. Once the form is submitted (via ajax) it start to fire an infinite loop of errors in console (onloadwff.js:68 Uncaught TypeError: o.val is not a function). It is really annoying and should be fixed as soon as possible. If there is a workaround please let us know the solution and we will implement it in our forms. Thanks.
Andrea
 
Posts: 1
Joined: Tue Oct 31, 2017 6:39 am

Re: Chrome javascript error - onloadwff.js:68

Postby tmstark586 » Sat Feb 10, 2018 8:08 am

This needs to be fixed. It's breaking my software for people who use lastpass. Unacceptable.
tmstark586
 
Posts: 1
Joined: Sat Feb 10, 2018 8:06 am

Re: Chrome javascript error - onloadwff.js:68

Postby berglion » Tue Mar 06, 2018 6:19 am

This needs to be fixed. It's breaking my software for people who use lastpass. Unacceptable.

Completely agree. Can't workaround by changing ids.
berglion
 
Posts: 1
Joined: Tue Mar 06, 2018 6:17 am

Re: Chrome javascript error - onloadwff.js:68

Postby chris732 » Tue Mar 06, 2018 11:41 pm

This needs to be escalated.
chris732
 
Posts: 1
Joined: Mon Jan 29, 2018 10:03 pm

Re: Chrome javascript error - onloadwff.js:68

Postby danspam » Thu Mar 15, 2018 1:25 am

Experiencing this issue too. Please fix!
danspam
 
Posts: 1
Joined: Thu Mar 15, 2018 1:24 am

Next

Return to General Support & Troubleshooting

Who is online

Users browsing this forum: Google [Bot] and 25 guests