Safari 10 binary will not install

Have questions about LastPass, or having problems using it? Ask for help here!

Moderators: admin, Israel, anatoly_LP, chantieLP, robyn, JoeSiegrist

Re: Safari 10 binary will not install

Postby howdoogie » Mon Dec 26, 2016 5:19 am

Same problem, I've tried installing the binary component multiple times. Still "Binary Component: false" and cannot set idle timer.
macOS Sierra 10.12.1
Safari Version 10.0.1 (12602.2.14.0.7)
I have been a paying customer for years.
This needs to be fixed asap or we'll have to switch to 1password.
Thank you.
howdoogie
 
Posts: 3
Joined: Wed Feb 24, 2016 11:14 am

Re: Safari 10 binary will not install

Postby pvanberlo » Mon Dec 26, 2016 8:29 am

LastPass doesn't seem to be in a hurry to get this fixed, I understand that it takes time, but Sierra has been available for a while now...
pvanberlo
 
Posts: 2
Joined: Mon Dec 26, 2016 8:27 am

Re: Safari 10 binary will not install

Postby pvanberlo » Mon Dec 26, 2016 9:13 am

Same issue here, would be nice if LastPass would at least respond in more detail and tell us when to expect a fix. It's not like any 'major changes' come as a surprise, most developers have access to the developer betas of Apple products. Seems like this is not considered urgent/important enough to fix quickly. Which is really too bad...
pvanberlo
 
Posts: 2
Joined: Mon Dec 26, 2016 8:27 am

Re: Safari 10 binary will not install

Postby petry818 » Tue Dec 27, 2016 9:33 am

I suggest to use other password manager. Not able to log out after idle is serious lack of usability and it can be danger to your security. And support just doesn't care. After several months did nothing with this problem.
petry818
 
Posts: 1
Joined: Tue Dec 27, 2016 9:24 am

Re: Safari 10 binary will not install

Postby Thorz » Tue Dec 27, 2016 10:56 pm

Even after you manually enable the binary component in Safari it still doesn't work as it should. I guess that's the reason for that they have not enabled it automatically. Try for yourselves:
Install the universal LP installer app and then launch:
~/Library/Application Support/LastPass/LastPassHelper.app
Now the binary component is enabled (TRUE) in Safari.
You can even add this app under macOS Preferences/Users & Groups/Login Items to launch it automatically at logon.
BUT:
- LP still have a lot of problems sharing logon state between browsers (I use Chrome and Safari).
- Automatically Log out when all browsers are closed and Safari has been closed for (mins) 60 does not work as expected: If you close Safari you ALMOST always have to authenticate again in LP.
- Automatically Log out after idle (mins) 180: Same as the previous point.
All this functions work perfectly under Chrome.
I have created a very detailed support case on this, let's see what LP support has to say, but I don't make me any illusions, this has been an issue that has been present for a long time. I think they just plainly are not dedicating enough resources to solve this.
Thorz
 
Posts: 20
Joined: Wed Feb 02, 2011 7:40 am

Re: "Copy Password" option gone in Safari (Yosemite)

Postby scx » Sat Dec 31, 2016 1:20 pm

same here
scx
 
Posts: 2
Joined: Sat Dec 31, 2016 1:19 pm

Re: Safari 10 binary will not install

Postby asam221 » Sun Jan 01, 2017 1:39 pm

I would also really like to stress the importance of this to the LastPass team.
My default browser is Chrome, but I 've been using Safari lately as part of some work I am doing, and I have to say that not having the features of binary support, and especially lacking the ability to set an idle log out time limit, is a pretty high security risk.
I know there are challenges with how Apple updates their OS and often break functionality and backwards compatibility, but it seems from the comments that folks using older versions of the OS (not necessarily Sierra) are having the same issue, and it's been happening for a while.
In addition, the absence of additional features like copying a username or a password is absent, which is pretty disappointing.
I hope this issue can be tackled soon, or at least someone from the team can provide us with an estimate of when this will be addressed.
asam221
 
Posts: 2
Joined: Sun Jan 01, 2017 1:27 pm

Re: Safari 10 binary will not install

Postby cab0419 » Mon Jan 02, 2017 1:29 am

I am having the same problem using Sierra 10.12.2 and Safari 10.0.2.

Not having auto logoff presents some real security problems. Time to start looking for another password manager?
cab0419
 
Posts: 1
Joined: Mon Jan 02, 2017 1:25 am

Re: Safari 10 binary will not install

Postby calcio109 » Mon Jan 02, 2017 8:05 pm

+1; same here; finally attempting to migrate away from a PC to a Mac, and lo and behold what is one of the biggest difficulties i'm finding with the transition - lastpass not working properly in safari. let's go on with LP, sierra and safari 10 have been available for some time, and certainly in beta form before that.
calcio109
 
Posts: 16
Joined: Thu Apr 07, 2011 11:17 pm

Re: Safari 10 binary will not install

Postby gaboose990 » Tue Jan 03, 2017 10:32 am

Same issue here - trying to upload a secure document for an immediate need, and it just doesn't work in Safari no matter what I do (uninstall, reinstall, enable tool bar, etc). Binary compatibility with safari is the obvious issue, and looking at this post it has been going on for AGES. PLEASE FIX.
gaboose990
 
Posts: 2
Joined: Tue Jan 03, 2017 10:30 am

PreviousNext

Return to General Support & Troubleshooting

Who is online

Users browsing this forum: Google Feedfetcher, michaelw842, mkyp and 61 guests