Safari 10 binary will not install

Have questions about LastPass, or having problems using it? Ask for help here!

Moderators: admin, anatoly_LP, chantieLP, Israel, JoeSiegrist, robyn

Re: Safari 10 binary will not install

Postby MrW42 » Sun Nov 27, 2016 6:22 pm

This problem concerns me. I have been told by a professional computer repair guy that LastPass is vulnerable to hacking. He advised me not to use it. This problem is lending weight to his argument.
MrW42
 
Posts: 2
Joined: Sun Nov 27, 2016 6:20 pm

Re: Safari 10 binary will not install

Postby mattybbeme » Wed Nov 30, 2016 12:33 am

Same problem here! frustrating!
mattybbeme
 
Posts: 1
Joined: Wed Nov 30, 2016 12:31 am

Re: Safari 10 binary will not install

Postby kalendarev766 » Thu Dec 01, 2016 4:56 am

Same problem. Need to pay for premium but waiting for solution. It's very insecure the missing idle function.
kalendarev766
 
Posts: 2
Joined: Thu Dec 01, 2016 4:51 am

Re: Safari 10 binary will not install

Postby MrW42 » Thu Dec 01, 2016 6:06 am

Anyone know if other password managers are better? I read that Dashlane might be one of the top password managers. I might switch if LastPass does not address the installation issue.
MrW42
 
Posts: 2
Joined: Sun Nov 27, 2016 6:20 pm

extension won't install in Safari

Postby andrewhockley232 » Wed Dec 07, 2016 4:44 am

I am running Capitan. Last pass installs into Chrome OK, but will not install in Safari. I have tried installing from the Apple extensions store and also using Lastpass binary - I get the same generic "A problem occurred try later" message. I have "tried later" and that didn't work either. I have to say, the concept of LastPass is great, but in practice it is hard to use and has that not-quite-finished-buggy feel that I remember from 1980s software releases. Should I be trusting it with my most sensitive data?
andrewhockley232
 
Posts: 1
Joined: Tue Dec 06, 2016 5:48 am

Re: Safari 10 binary will not install

Postby jacknimble » Wed Dec 07, 2016 4:08 pm

Same here on a brand-new Mac. PLEASE FIX THIS. Paying, Enterprise customer here. We influence sales of LastPass to our clients - some of whom have Macs.

Once again, PLEASE FIX THIS.

This issue is at least 2 months old.
jacknimble
 
Posts: 7
Joined: Sat Apr 21, 2012 8:01 pm

Re: Safari 10 binary will not install

Postby hanLP » Wed Dec 07, 2016 6:42 pm

Sorry about that. We do not have any ETA for the fix but have bumped the internal report again. I will update the forum when the fix is available. Thank you for your patience in the meantime.
hanLP
 
Posts: 194
Joined: Tue Dec 24, 2013 2:26 pm

Binary does not work on Safari 10.0.1 Sierra

Postby Vaelin » Thu Dec 15, 2016 2:49 pm

I have tried uninstalling and reinstalling the Lastpass extension for Sarafi 10.0.1, but I cannot get binary to install. It always stays at Binary: False.

I assume this is a bug rather than the fault of the user. I have seen that people are having the same problem with Chrome on Windows.
Vaelin
 
Posts: 1
Joined: Thu Dec 15, 2016 2:46 pm

Re: Safari 10 binary will not install

Postby djbond » Sun Dec 18, 2016 11:41 am

Just became a LP customer two days ago... and sadly the same bloody problem with Safari.

The problem it seems is that with macOS Sierra, Apple changed the structure of Safari - moving their existing Safari Extensions to native App Extensions, with the aim of making it easier for developers to do it in Xcode.

The new architecture will support App Extensions built from a combination of JavaScript, CSS and native code written in Objective-C or Swift, according to an article in AppleInsider. The full article is here: http://appleinsider.com/articles/16/06/ ... eb-content

I don't know why the LastPass tech people couldn't be a bit more clear by at least saying something to the effect that 'Apple has changed the structure of Safari and we need to rewrite the LastPass extension for it' - that would be a bit more upfront instead of saying they are 'looking at the issue' .

So please LastPass engineers lets get the coding done asap.
djbond
 
Posts: 1
Joined: Sun Dec 18, 2016 11:28 am

Re: Safari 10 binary will not install

Postby mw411 » Tue Dec 20, 2016 6:21 am

same problem with Safari 10.0.2 (11602.3.12.0.1) on a OS X 10.11.6 system (El Capitan), so it's NOT a sierra-only issue.

"error while installing the extension 'LastPass'"
mw411
 
Posts: 2
Joined: Tue Dec 20, 2016 6:16 am

PreviousNext

Return to General Support & Troubleshooting

Who is online

Users browsing this forum: Google [Bot] and 62 guests