Disable Lastpass for localhost

Have questions about LastPass, or having problems using it? Ask for help here!

Moderators: admin, Israel, anatoly_LP, chantieLP, robyn, JoeSiegrist

Re: Disable Lastpass for localhost

Postby StormFiber » Fri Nov 30, 2018 1:27 am

Please use this IP address: 127.0.0.1 to set a Never URL in your LastPass Icon > My LastPass Vault > Account Settings > Never URLs tab, it should then respect the request on your localhost sites.
StormFiber
 
Posts: 9
Joined: Wed Nov 28, 2018 3:48 am

Re: Disable Lastpass for localhost

Postby heyvian » Mon Dec 10, 2018 3:23 pm

Please fix this. Seems like a bug where LastPass is not respecting localhost Never URLs. I've added the URLs as suggested.

https://imgur.com/MCxYqUL
heyvian
 
Posts: 2
Joined: Mon Dec 10, 2018 3:17 pm

Re: Disable Lastpass for localhost

Postby larryh » Wed Dec 19, 2018 5:39 pm

I echo just about everything that's been written: as a web developer this is *extremely annoying*, and adding 127.0.0.1 and localhost had no effect.

This seems like it should be a simple thing to do - indeed, I imagine the LastPass Devs incorporated this functionality during the first week or month of their coding this product.

Are there any updates on this? I just signed up for LastPass but if I can't turn the $#@! thing off locally I'll have to pick another product. Also, how do we find out the status on this? Do we have to keep checking this page?
larryh
 
Posts: 3
Joined: Wed Dec 19, 2018 5:32 pm

Re: Disable Lastpass for localhost

Postby heyvian » Wed Jan 02, 2019 4:35 pm

They decided to finally stop ignoring me on Twitter

They say they're looking into it https://twitter.com/LastPassHelp/status ... 9704147973
heyvian
 
Posts: 2
Joined: Mon Dec 10, 2018 3:17 pm

Re: Disable Lastpass for localhost

Postby larryh » Thu Jan 03, 2019 10:57 am

Thanks for the heads up on this, @heyvian
larryh
 
Posts: 3
Joined: Wed Dec 19, 2018 5:32 pm

Re: Disable Lastpass for localhost

Postby wattyrev » Fri Feb 08, 2019 7:05 pm

I have not been able to get this to work. Can we figure out a solution? Lastpass budding in to my localhost development is super annoying. I just want to disable the plugin whenever I'm on localhost.
wattyrev
 
Posts: 1
Joined: Sat Jan 12, 2019 9:09 pm

Re: Disable Lastpass for localhost

Postby larryh » Wed May 08, 2019 5:43 pm

Well, here it is several months later and still nothing. Talk about infuriating. And not just the behavior, but the inability to get anyone from LastPass to address this issue or to find out if it's even being worked on.
larryh
 
Posts: 3
Joined: Wed Dec 19, 2018 5:32 pm

Re: Disable Lastpass for localhost !!!! SOLVED !!!!

Postby tonymrichardson425 » Wed Sep 25, 2019 5:56 pm

I figured out the issue.... at least I figured it out for me and I think this will work for most others.

Just like others, I tried http://localhost and I tried the local IP...nothing worked. I even created a virtual host with a unique name... it didn't work either. So I decided to let last pass create a password and I opened it to see what lastpass used for the URL. That's how I found out that it was quite simple actually...

If you have a localhost, hopefully you have directories for your work. All I had to do was add http://localhost/Directory under the "Do Nothing" Category, and it never popped up again. Also, this wasn't just for the index.php file. It also worked for files and classes inside my code that required password validation or password resets. It worked in every case. The only draw back is that you have to add every directory... or you could simply add a master folder in your localhost directory and that would work.

and not only did the index.php file work, but every think inside like password resets and and password verification for secured areas.... everything inside was exempt.

I hope if works for you too... good luck!!
tonymrichardson425
 
Posts: 1
Joined: Wed Sep 25, 2019 5:38 pm

Re: Disable Lastpass for localhost

Postby Erwin123456 » Wed Dec 11, 2019 7:27 am

Any update?
Erwin123456
 
Posts: 1
Joined: Wed Dec 11, 2019 7:27 am

Re: Disable Lastpass for localhost

Postby Foton » Wed Jul 22, 2020 4:16 am

I just add `http://localhost:3000` to my "Never do anything" and it seems to work. SO my quess is: You have to have "something" after `localhost/`. Luckilly deve servers fro Ruby on Rails runs by default on 3000 port.
Foton
 
Posts: 1
Joined: Wed Jul 22, 2020 4:12 am

PreviousNext

Return to General Support & Troubleshooting

Who is online

Users browsing this forum: bosspublic351 and 38 guests