Fingerprint reader issue in Standard User account

Help with the Windows installer (lastpass.exe)

Moderators: admin, anatoly_LP, chantieLP, robyn, JoeSiegrist

Fingerprint reader issue in Standard User account

Postby PNutts » Sun Dec 30, 2012 2:55 am

Hi all.

Windows 7 x64, IE 9 (32 bit), LastPass version 2.0.2, using a Standard User account. When I install, as expected I'm prompted for the Windows' Administrator account password. LastPass recognizes there is a fingerprint reader and prompts me to use it. I can successfully register a fingerprint and complete the installation.

The issue is when I launch IE "normally" (not Run as Administrator), LastPass does not recognize the fingerprint reader and prompts me for my Master Password. However, if I launch IE as Administrator (Run as Administrator) LastPass recognizes the fingerprint reader and can be used to authenticate.

I would like to run IE in the Standard User account without elevated permissions and use the fingerprint reader.

Thank you for any assistance.
PNutts
 
Posts: 5
Joined: Sun Dec 30, 2012 2:22 am

Re: Fingerprint reader issue in Standard User account

Postby drew » Mon Dec 31, 2012 9:59 am

I am unable to reproduce. Please follow these instructions to generate debug logs, and either attach them here or email them to drew@lastpass.com:

https://lastpass.com/debug.php#ie

Since you will have to run IE as non-admin to reproduce, your logs will end up in the second listed location, not the first:

- C:\Users\<your_windows_username>\AppData\LocalLow\LastPass\debug.txt (eg:C:\Users\johndoe\AppData\LocalLow\LastPass\debug.txt)
drew
 
Posts: 1081
Joined: Tue Aug 19, 2008 5:47 pm
Location: Washington, DC USA

Re: Fingerprint reader issue in Standard User account

Postby PNutts » Mon Dec 31, 2012 7:24 pm

Drew:

I just sent the files.

Thank you!
PNutts
 
Posts: 5
Joined: Sun Dec 30, 2012 2:22 am

Re: Fingerprint reader issue in Standard User account

Postby drew » Wed Jan 02, 2013 10:57 am

It appears the debug files you sent are from the installer. Did you get them from c:\? If so, please look in the location I mentioned in my last post instead.
drew
 
Posts: 1081
Joined: Tue Aug 19, 2008 5:47 pm
Location: Washington, DC USA

Re: Fingerprint reader issue in Standard User account

Postby PNutts » Wed Jan 02, 2013 4:40 pm

I've just sent debug.txt from C:\Users\<your_windows_username>\AppData\LocalLow\LastPass\debug.txt. Sorry for the confusion.
PNutts
 
Posts: 5
Joined: Sun Dec 30, 2012 2:22 am

Re: Fingerprint reader issue in Standard User account

Postby drew » Wed Jan 02, 2013 4:49 pm

debug.txt is actually an unrelated file. We need:

C:\Users\<your_windows_username>\AppData\LocalLow\LastPass\lastpass_*.txt
drew
 
Posts: 1081
Joined: Tue Aug 19, 2008 5:47 pm
Location: Washington, DC USA

Re: Fingerprint reader issue in Standard User account

Postby PNutts » Thu Jan 03, 2013 11:44 am

Hi Drew. Here are no lastpass_*.txt files being generated in the ..\LocalLow\LastPass folder, only the debug.txt. It turns out the files are in C:\Users\<user>\AppData\Local\Temp\Low. The wildcard is a four digit number in the filename, e.g., lastpass_1234.txt. I'll take the chance these are the flles you're looking for and send one to you in a few moments. Thx.
PNutts
 
Posts: 5
Joined: Sun Dec 30, 2012 2:22 am

Re: Fingerprint reader issue in Standard User account

Postby drew » Thu Jan 03, 2013 11:47 am

Oops, yeah that looks right.
drew
 
Posts: 1081
Joined: Tue Aug 19, 2008 5:47 pm
Location: Washington, DC USA

Re: Fingerprint reader issue in Standard User account

Postby drew » Thu Jan 03, 2013 2:57 pm

Can you try going back into Account Settings while you're running IE as a standard user, and toggling the fingerprint checkbox to see if you can re-set it up?
drew
 
Posts: 1081
Joined: Tue Aug 19, 2008 5:47 pm
Location: Washington, DC USA

Re: Fingerprint reader issue in Standard User account

Postby PNutts » Thu Jan 03, 2013 8:59 pm

Wow. With this debug version I am able to toggle the setting and it prompts me for my fingerprint and accepts it! It's working normally. On the non-debug version when I tried to enable Fingerprint Reader Authentication it would take me into my "fingerprint software" and would not enable the feature.

Can I keep the debug version? :)
PNutts
 
Posts: 5
Joined: Sun Dec 30, 2012 2:22 am

Next

Return to Windows Installer Questions

Who is online

Users browsing this forum: No registered users and 2 guests