Page 1 of 2

No Plug-in with Avant Browser

PostPosted: Tue Apr 28, 2009 10:38 am
by pensbury
I've installed LastPass, and imported all my login/password data from RoboForm.

I have both IE8 and Firefox installed (with both of which LastPass works fine) but my preferred browser of choice is Avant.

The plugin icon does not show in Avant - and I just can't seem to find a way to make it do so. I understand that Avant is built over IE and the icon is ther on IE so I'm mystified.

Help? Advice? Please!

Re: No Plug-in with Avant Browser

PostPosted: Tue Apr 28, 2009 10:50 am
by JoeSiegrist
Avant's plugin system is terrible, just like Maxthon Classic's: they load and unload plugins every time you switch tabs, the most inefficient way I can possibly think to implement plugins. They should fix it.

Re: No Plug-in with Avant Browser

PostPosted: Tue Apr 28, 2009 5:14 pm
by pensbury
Good news - I asked the question on the Avant support forum and got a quick reply

Go to Tools >> Avant Browser Options >> Add-ons >> IE Plug-ins
Check 'LastPass Toolbar'
(I also checked the items 'LastPass' and 'LastPass Fill Forms' )


Then go to View >> Toolbars >> LastPass Toolbar

Works for me - yay!

Re: No Plug-in with Avant Browser

PostPosted: Wed Apr 29, 2009 11:29 am
by pensbury
Ooooops!!

I spoke too soon.

Yes, that procedure makes the toolbar appear - but it's unusable since, the instant I change tabs, the LastPass icon disappears, leaving an empty and useless toolbar.

Anyone any advice?

Re: No Plug-in with Avant Browser

PostPosted: Wed Apr 29, 2009 6:09 pm
by JoeSiegrist
pensbury Wrote:Anyone any advice?


Ask Avant why they've made their plugin system unload every plugin every time you switch tabs. They should fix it.

Re: No Plug-in with Avant Browser

PostPosted: Wed Apr 29, 2009 7:27 pm
by pensbury
Avant seem to blame LastPass!

They claim version 1.4 worked fine, but suggest there's some kind of bug in LastPass 1.5

Should I uninstall 1.5 and replace it with 1.4?

Re: No Plug-in with Avant Browser

PostPosted: Thu Apr 30, 2009 3:50 pm
by JoeSiegrist
pensbury Wrote:Avant seem to blame LastPass!

That's funny -- it never worked, and their system of unloading and reloading the add-ons for every tab switch is to blame as it's always been.

Re: No Plug-in with Avant Browser

PostPosted: Thu Apr 30, 2009 4:17 pm
by pensbury
So, are you saying that LastPass will NOT work with Avant?

Re: No Plug-in with Avant Browser

PostPosted: Thu Apr 30, 2009 4:25 pm
by JoeSiegrist
I'm saying Avant is fundamentally broken, and we don't know how to deal with their browser. To sum up LastPass' point of view:

Deleting every addon and then re-adding every add-on with every tab switch is horribly inefficient and we don't know why they'd do something so obviously disadvantageous to their customers. This is the slowest possible way we could possibly think to implement a tab browser, IE for all it's faults is orders of magnitude faster.

If they'd like to work with us to fix it we'd be happy to do so.

Re: No Plug-in with Avant Browser

PostPosted: Wed May 13, 2009 5:23 pm
by pensbury
I've not posted a reply because I've been away visiting friends and relatives for a while.

Before I went away I uninstalled LastPass 1.5 and installed 1.46 - no difference! I then uninstalled LastPass 1.46 and installed 1.40 - success, up to a point. The LastPass toolbar AND icon remain when switching tabs - but logs out so I have to re-login every time I change tabs.

Now I'm back home, I'll see if I can get it to work better, get used to it, or give up on either LastPass or Avant. Let's see.