lastpass.exe did not complete installation

Help with the Windows installer (lastpass.exe)

Moderators: admin, anatoly_LP, chantieLP, robyn, JoeSiegrist

lastpass.exe did not complete installation

Postby LastP2 » Sun Sep 26, 2010 6:19 pm

Operating system is Windows 2000 SP4
I downloaded lastpass.exe, renamed it to lastpass_1690.exe and ran it
I used advanced installation options to install lastpass on D: drive
I am using Firefox 3.6.8 with profile manager with muliple users
Firefox on D: drive and user files on E: drive and on F: drive
lastpass_1690.exe terminated with error message on next line
"The procedure InternetSetCookieExW could not be located in the DLL WININET.dll.
Please advise on procedure for successful installation
LastP2
 
Posts: 2
Joined: Sun Sep 26, 2010 5:52 pm

Re: lastpass.exe did not complete installation

Postby brantgurga » Thu Sep 30, 2010 12:40 am

Do you have the legitimate wininet.dll available? If you've done something like hackishly remove Internet Explorer, it could be missing.
brantgurga
 
Posts: 417
Joined: Wed Nov 04, 2009 10:37 am
Location: Indianapolis, IN

Re: lastpass.exe did not complete installation

Postby LastP2 » Thu Sep 30, 2010 11:05 pm

Sorry, should have posted update earlier
I also contacted support@lastpass.com
They replied within about 24 hours
They told me to try https://lastpass.com/lp_win.xpi
I did and it works. Turns out to be LastPass 1.69.1
Then I discovered https://lastpass.com/releases
The lastest Firefox version is lp1.69.1.xpi
So I Uninstall LastPass and installed using lp1.69.1.xpi
I am now experimenting with LastPass 1.69.1

Hello brantgurga
As far as I know my wininet.dll is the original that came with Windows 2000 SP4
I do not know how and I did not try to remove Internet Explorer
So I started Internet Explorer and my version is 5.50.4134.0600
I have a strong bias against updating Internet Explorer
I only keep it around in case I need to do MS Windows Update
I will assume my problems with wininet.dll is due to age of Internet Explorer
LastP2
 
Posts: 2
Joined: Sun Sep 26, 2010 5:52 pm

Re: lastpass.exe did not complete installation

Postby brantgurga » Thu Sep 30, 2010 11:14 pm

I found your issue: That function is not in Windows 2000 if you look up its documentation at http://msdn.microsoft.com/en-us/library/aa385108(VS.85).aspx

Technically, I don't believe LastPass supports Windows 2000. However, the XPI should work for Firefox because it does not involve calling that function to my knowledge.
brantgurga
 
Posts: 417
Joined: Wed Nov 04, 2009 10:37 am
Location: Indianapolis, IN


Return to Windows Installer Questions

Who is online

Users browsing this forum: No registered users and 5 guests