Page 1 of 3

X64 IE8 Win7 missing reg entry

PostPosted: Tue Jan 26, 2010 5:33 am
by WEBPC
I am trying LastPass and it works in the 32 bit browsers but every time I launch 64bit IE8 (or a new tab) I get the error:
"An installation error has been detected with LastPass. This will result in reduced functionality. Please reinstall.
You are missing a registry entry: Software\LastPass\TBLangDir"
Found an old forum thread (viewtopic.php?f=11&t=2379&p=24739) but it appears to be outdated as a newer version of Lastpass is out.
I have tried an uninstall/ reinstall which hasn't helped
Any ideas on how to fix?
TIA
Antony

Re: X64 IE8 Win7 missing reg entry

PostPosted: Tue Jan 26, 2010 11:38 am
by JoeSiegrist
Can you run 'regedit' and see if HKEY_CURRENT_USER\Software\LastPass exists? That's where we expect to find TBLangDir key which should point to where you installed LastPass.
Are you installing as one user and running as another user?

Re: X64 IE8 Win7 missing reg entry

PostPosted: Tue Jan 26, 2010 12:40 pm
by WEBPC
HKEY_CURRENT_USER\Software\LastPass does exist.
Yes I installed whilst logged on as a restricted user and entered the Administrator user/password when prompted. I am trying to run as the restricted user.
Antony

Re: X64 IE8 Win7 missing reg entry

PostPosted: Wed Jan 27, 2010 12:43 am
by JoeSiegrist
That should work -- for now I'd suggest installing as admin user directly and we'll check into your case.

Re: X64 IE8 Win7 missing reg entry

PostPosted: Thu Jan 28, 2010 11:21 am
by WEBPC
OK I uninstalled LastPass, rebooted and logged in as an Administrator. Using IE8 64bit I went to the lastpass site and installed the 64bit program, then rebooted.
Logged in as Administrator, started IE8 64bit and the error didn't appear.
Logged out as Administrator and back in as a normal user. When I started IE8 64bit the same error about the missing registry key appeared.
Any suggestions?
Antony

Re: X64 IE8 Win7 missing reg entry

PostPosted: Thu Jan 28, 2010 1:29 pm
by sameer
Thanks for the detailed bug report.
We've been able to reproduce this and are working on a fix.
We'll post back to this forum thread when it's ready.

Re: X64 IE8 Win7 missing reg entry

PostPosted: Thu Jan 28, 2010 8:24 pm
by JoeSiegrist
Can you try https://lastpass.com/lastpass_x64pre.exe and let us know how it goes?

Re: X64 IE8 Win7 missing reg entry

PostPosted: Thu Jan 28, 2010 11:01 pm
by sameer
Quick additional note:

When testing:
- Log in as an administrator and install
- If other Windows users are currently logged in, you'll have to either log them off and back in, or reboot your machine.

Thanks

Re: X64 IE8 Win7 missing reg entry

PostPosted: Fri Jan 29, 2010 1:49 pm
by Jonno
I downloaded this, closed all browsers, and ran it as administrator. At the end of the install, I get the Program Compatibility Assistant box that says that the program may not have installed correctly, with options to reinstall using recommended settings or click "This program installed correctly." If I select the latter, when I go into IE8, the Lastpass toolbar button appears, but if I click on it, nothing happens (no menu appears). If I repeat the install, I do not get the PCA box, but I have the same results...button appears but does nothing when clicked. This is Win7 pro, 64bit, on active dir domain. Acct used has local admin rights, no other users are logged on. There are GPOs that restrict certain activity for security sake. Values in HCU\Software\LastPass\Software are:
(Default) REG_SZ (value not set)
AutoLogoffClose REG_SZ 0
FormSuggest Passwords REG_SZ no
FormSuggestP PW Ask REG_SZ no
globalinstallts REG_DWORD 0x4b631e72 (1264787058)
IEToolbarNeedsInit REG_SZ true
installoption_addtoquicklaunch REG_DWORD 0x00000001 (1)
same for _disableff, _disableeie, _toolbarff
installoption_installalluser REG_SZ All
intalluser REG_SZ All
localinstallts REG_DWORD 0x4b631e75 (1264787061)
LoginUsers (looks fine, redacted)
LPInstallDir REG_SZ C:\ProgramFiles (x86)\LastPass
lptempdir REG_SZ C:\Users\me\AppData\Local\Temp|lptmp23990
PageOpenTab REG_SZ 0
setloggoffonbrowserexit REG_DWORD 0x00000000 (0)
TBLanDir REG_SZ C:\ProgramFiles (x86)\LastPass\lang

Re: X64 IE8 Win7 missing reg entry

PostPosted: Mon Feb 01, 2010 10:54 am
by sameer
I cant reproduce it not working with the prebuild that I sent you (it definitely is not working properly in the normal build).
I'm not testing on an active directory domain, but otherwise, I think my setup is the same: Win7 Ultimate 64bit with IE8.

Is there anything else you can think of that would help me reproduce what you're seeing?

Here's the exact procedure I'm following to try and reproduce:
- I have 2 users: admin user and standard user
- I installed as the admin user with the standard user NOT logged in
- Got the PCA box, but clicked OK
- Used Fast User Switching to then log in the standard user
- As the standard user, I started up IE 32bit to make sure that I could login to LastPass
- As the standard user, I started up IE 64bit to make sure that I could login to LastPass

Thanks