Installer works for IE 11 but not Firefox 46

Help with the Windows installer (lastpass.exe)

Moderators: admin, anatoly_LP, chantieLP, JoeSiegrist, robyn

Installer works for IE 11 but not Firefox 46

Postby AlphaCharlie » Thu May 05, 2016 11:51 pm

I am running a Win7 Pro machine.
First, I UNinstalled LP ver 3 which worked fine for a couple of years.
Then I got LastPass for Windows from the main download page: https://lastpass.com/download/cdn/lastpass_x64.exe

The installer seemed to run fine, with no error messages.
Now I do see the LP icon in IE 11, but no LP icon in Firefox version 46.0.1

However, when I look at Tools, Add-ons, Plugins there is an entry for NPLastPass 4.1.2.0
It does not seem to matter if "Ask to activate" or "Always activate" is selected.

Firefox is my main brower, IE is just kept as a backup.

So what should I do next to make LP work correctly in Firefox?
Thank you.
LP Premium User
AlphaCharlie
 
Posts: 21
Joined: Sun Jan 23, 2011 6:15 pm

Re: Installer works for IE 11 but not Firefox 46

Postby jpenny84 » Fri May 06, 2016 12:32 am

The NPLastPass item Firefox is detecting in about:plugins is the binary component that other browsers use: https://lastpass.com/support.php?cmd=showfaq&id=5836

The extension was probably installed, but not enabled due to new signature requirements Mozilla has implemented. I would navigate to about:addons , remove any LastPass extensions and install the latest version in the Mozilla Add-On store: https://addons.mozilla.org/en-US/firefo ... /versions/
jpenny84
 
Posts: 8290
Joined: Tue Mar 06, 2012 9:10 pm

Re: Installer works for IE 11 but not Firefox 46

Postby AlphaCharlie » Fri May 06, 2016 11:32 am

Looking in Firefox, "Tools, Add-Ons, Extensions" Lastpass did not appear, so there was nothing to remove.
Next, I went to "Tools, Add-Ons, Get Add-Ons" and searched for Lastpass, which found an installer for LP version 3.3.1, and that seems to work.
Thank you.
AlphaCharlie
 
Posts: 21
Joined: Sun Jan 23, 2011 6:15 pm

Re: Installer works for IE 11 but not Firefox 46

Postby BernadetteLP » Mon May 16, 2016 8:07 am

@AlphaCharlie, please try reinstalling using this direct download link: https://lastpass.com/lastpassffx/ Let me know how it goes. Thanks!
BernadetteLP
 
Posts: 24
Joined: Sun Oct 06, 2013 4:05 pm

Re: Installer works for IE 11 but not Firefox 46

Postby AlphaCharlie » Mon May 16, 2016 11:24 am

Thank you BernadetteLP.
I ran that installer without seeing any errors, so now I have updated my Firefox add-on,
from LP Version 3.3.1 to LP version 4.1.7a
I will let you know if there are any problems as I use it this week.
AlphaCharlie
 
Posts: 21
Joined: Sun Jan 23, 2011 6:15 pm

Re: Installer works for IE 11 but not Firefox 46

Postby lite11 » Mon May 16, 2016 11:40 pm

Bernadette I have been LP premium user for years on FF46 and Windows 7 Pro 64 bit OS. I have tried repeatedly using the direct download link you provided in your post (actually ahd done that before finding the forum as well). After clicking Allow for the activity and it seemingly completes the about 11MB file I get the error message "The add-on could not be completed due to a connection failure" or similar wording.

Upgrading LP is often a nightmare, and our company just started using the Enterprise version which has tons of gotchas to get it to work even marginally.

Thanks for any further thoughts on upgrading the FF add-on.
lite11
 
Posts: 27
Joined: Tue Jun 11, 2013 3:35 pm

Re: Installer works for IE 11 but not Firefox 46

Postby jpenny84 » Tue May 17, 2016 12:44 am

lite11 Wrote:Bernadette I have been LP premium user for years on FF46 and Windows 7 Pro 64 bit OS. I have tried repeatedly using the direct download link you provided in your post (actually ahd done that before finding the forum as well). After clicking Allow for the activity and it seemingly completes the about 11MB file I get the error message "The add-on could not be completed due to a connection failure" or similar wording.

Upgrading LP is often a nightmare, and our company just started using the Enterprise version which has tons of gotchas to get it to work even marginally.

Thanks for any further thoughts on upgrading the FF add-on.


You can always try downloading the extension directly from addons.mozilla.org . If you still are getting connection errors, you will need to contact Mozilla and find out why extensions from their add-on store aren't installing.

https://addons.mozilla.org/en-US/firefo ... /versions/
jpenny84
 
Posts: 8290
Joined: Tue Mar 06, 2012 9:10 pm

Re: Installer works for IE 11 but not Firefox 46

Postby lite11 » Tue May 17, 2016 1:04 am

Thanks, it seems in checking my add-ons that I have in FF NPLastPass 4.1.2 so that is NOT the problem. I had downloaded the LastPass application assuming that it would overwrite my prior version 3.?? In control panel add/remove programs it only shows LastPass (uninstall only) with May 15, 2016 date so have no idea of what version of LP (not FF add-on I am running). I know it is not LP 4 as the appearance is NOT what I see when I am in the office which I know is using LP Enterprise 4. At home I am only using a personal version of LP, NOT Enterprise.

Do I need to uninstall LP and then install LP 4? If I uninstall, I'd certainly hope that all of my sites are re-established automatically in LP4.

Thanks for any help on this.
lite11
 
Posts: 27
Joined: Tue Jun 11, 2013 3:35 pm

Re: Installer works for IE 11 but not Firefox 46

Postby jpenny84 » Tue May 17, 2016 1:49 am

The NPLastPass plugin you see in about:plugins has to do with a binary component that other browsers use: https://lastpass.com/support.php?cmd=showfaq&id=5836

Removing any old LastPass extensions from about:addons is advisable to ensure a clean install. For Firefox, there's really no need to remove any components in Add/Remove Programs. All your sites are backed up and will migrate over automatically.
jpenny84
 
Posts: 8290
Joined: Tue Mar 06, 2012 9:10 pm

Re: Installer works for IE 11 but not Firefox 46

Postby lite11 » Sat May 21, 2016 1:28 am

@jpenny84 thank you very much. The only thing that worked was installing from https://addons.mozilla.org/en-US/firefo ... /versions/ which you had suggested. LastPass 4.1.7a from May 2, 2016 is there and is now finally working in Firefox. The forum was much more helpful than starting a trouble ticket that didn't help at all.
lite11
 
Posts: 27
Joined: Tue Jun 11, 2013 3:35 pm


Return to Windows Installer Questions

Who is online

Users browsing this forum: No registered users and 8 guests