Universal Installer installs v.3 instead of v.4

Help with the Windows installer (lastpass.exe)

Moderators: admin, anatoly_LP, chantieLP, robyn, JoeSiegrist

Universal Installer installs v.3 instead of v.4

Postby oao » Thu Apr 14, 2016 12:43 am

A while ago I had upgraded 3 to 4 free and everything was fine for both FFox and IE. Then I ran into some problems and I had to uninstall and reinstall.

When I run the universal installer 4.1.2. it prompts me to allow installation of version 3.2.4! I tried it twice with the same result. WHY?

I need an answer fast because I cannot access sites without LP.
oao
 
Posts: 4
Joined: Thu Apr 14, 2016 12:39 am

Re: Universal Installer installs v.3 instead of v.4

Postby jpenny84 » Thu Apr 14, 2016 9:46 am

Which browser has the old version?
jpenny84
 
Posts: 8381
Joined: Tue Mar 06, 2012 9:10 pm

Re: Universal Installer installs v.3 instead of v.4

Postby oao » Thu Apr 14, 2016 12:01 pm

Neither has any version yet: The installer prompts me to allow v. 3, at which point I stop, because I don't want to install that version.

Incidentally, now every login into LP or forum I am prompted to authenticate via the grid which is a big pain in the ass -- why? Has not happened before.

What a mess.
oao
 
Posts: 4
Joined: Thu Apr 14, 2016 12:39 am

Re: Universal Installer installs v.3 instead of v.4

Postby oao » Thu Apr 14, 2016 12:04 pm

One more thing: The email link to read the forum replies does not land me into replying, but into the forum and I need to navigate to the thread manually. Yuckh.
oao
 
Posts: 4
Joined: Thu Apr 14, 2016 12:39 am

Re: Universal Installer installs v.3 instead of v.4

Postby jpenny84 » Thu Apr 14, 2016 1:07 pm

At what step of the process is it saying that you are installing 3.2.4?
jpenny84
 
Posts: 8381
Joined: Tue Mar 06, 2012 9:10 pm

Re: Universal Installer installs v.3 instead of v.4

Postby oao » Thu Apr 14, 2016 3:33 pm

Did some digging.

1. Searched for any LP file leftovers after the uninstall. There were 1131 of them, even though I used a deep cleaner after the LP uninstall. I managed to delete most of them except two objects:

lastpass (lastpass.com)
lastpass - passwords made easy

which are referred to as History items and I can't delete them.

Searched for registry LP leftovers and found a lot (exported 11 of them to .reg files). Deleted all, did a registry cleanup and rebooted. LP 4 installed correctly.

I have no idea what effect the leftovers have, if any, on the install problem, but the number of items you store on the computer and in the registry and the fact that the LP uninstall leave them behind is are unacceptable and are sure to cause problems.

Pls forward this to management and have them explain what they're gonna do about it asap.
oao
 
Posts: 4
Joined: Thu Apr 14, 2016 12:39 am


Return to Windows Installer Questions

Who is online

Users browsing this forum: No registered users and 3 guests