Unable to upgrade or install latest version

Help with the Windows installer (lastpass.exe)

Moderators: admin, anatoly_LP, chantieLP, robyn, JoeSiegrist

Unable to upgrade or install latest version

Postby lsf11 » Fri Apr 10, 2015 1:40 pm

When I visited the support site (https://lastpass.com/support.php), I received the following notification:
You are running an old version of the LastPass plugin, version 3.1.54.
To upgrade to version 3.1.92, please click here.

I tried to click the upgrade link and received an error:
The add-on could not be downloaded because of a connection failure on lastpass.com

So I went to the downloads page and downloaded the latest Windows installer. When I tried to run that, I received an error:
Administrative privileges are required. Please ask your System Administrator for assistance. Error=C

Note that I am logged in using the administrator account on this machine. I tried running it by double-clicking, and by right-clicking and selecting "Run as administrator".

Please advise.
lsf11
 
Posts: 2
Joined: Fri Apr 10, 2015 1:36 pm

Re: Unable to upgrade or install latest version

Postby jpenny84 » Fri Apr 10, 2015 2:14 pm

Search the forum for connection failure, and you will find several topics with a fix. You will need to download the crx file using another browser and install it in Firefox manually.
jpenny84
 
Posts: 9165
Joined: Tue Mar 06, 2012 9:10 pm

Re: Unable to upgrade or install latest version

Postby lsf11 » Fri Apr 10, 2015 3:20 pm

Thanks for pointing me in the right direction jpenny84. I've now updated LastPass on FF.

I have to say I'm a little disappointed that this problem is so rampant yet LastPass hasn't (a) fixed it or (b) posted the workaround on their downloads page. The onus is on the software vendor, not the customer, to make sure the product installation works across all supported platforms and browsers.
lsf11
 
Posts: 2
Joined: Fri Apr 10, 2015 1:36 pm

Re: Unable to upgrade or install latest version

Postby jpenny84 » Fri Apr 10, 2015 3:35 pm

The problem seems to be with the browser, or how it's installed, not the extension. If you search for that error, it happens on other extensions too, not just LastPass.
jpenny84
 
Posts: 9165
Joined: Tue Mar 06, 2012 9:10 pm


Return to Windows Installer Questions

Who is online

Users browsing this forum: No registered users and 3 guests